Output.elasticsearch -> console


(Ecc256) #1

Guys,
How do I set output.elasticsearch to console only, without elasticsearch hosts?
If I do
# hosts: ["localhost:9200"]
console:
I get
Exiting: error initializing publisher: missing required field accessing 'output.elasticsearch.hosts' (source:'test.yml')

I do know, -e flag sends filebeat log to stderr.
I do want to run beat NOT in test mode with output to console instead of elasticsearch.
Is it possible?


(Adrian Serrano) #2

What you want is to use console output, which is a different kind of output than elasticsearch:

# output.elasticsearch:
#   hosts: ["localhost:9200"]

output.console:
  enabled: true
  pretty: true

For that you need to comment-out the elasticsearch output completely, not just the hosts field, as beats only allow one output to be specified.


(Ecc256) #3

Adrian,

Got it!
That’s exactly what I was missing! :blush:
Thanks a lot!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.