Disable filebeat console output


I'm having trouble disabling my filebeat's console output. I have stated in my filebeat.yml that console output should be enabled but it doesn't work. Do I need to configure it somewhere else as well as to the filebeat.yml? I am currently starting my filebeat with command:

sudo --preserve-env ./filebeat -e -c filebeat.yml -d "publish" --once

and my filebeat.yml looks like this:

- type: log

     index:  ${CURRENT_SERVER}-${DATE_USED}
  close_eof: true
  hosts: MY HOST
  enabled: false

I am not sure if the output is even caused by filebeat. The output that I'm trying to disable looks like this:

TIMESTAMP	DEBUG	[publish]	pipeline/processor.go:275	Publish event: {
  "@timestamp": TIMESTAMP
  "@metadata": {
    "beat": "filebeat",
    "type": "doc",
    "version": VERSION
  "offset": OFFSET
  "message": MESSAGE
  "prospector": {
    "type": "log"
  "fields": {
    "index": INDEXNAME
  "beat": {
    "name": NAME
    "hostname": NAME
    "version": VERSION
  "source": SOURCE

-e flag makes filebeat to log to stderr.

If you want to reduce the level of logs printed you can use logging.level option.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.