Override default umask

I understand the dev team has hardcoded the umask to 0027 in libbeats so this applies to all beats apps. Is there a way to override this in the configuration file or CLI parameter?

It does not look like the struct field in instance.Settings that is used to hold the umask is ever set, so it looks like no. The only reference I can find to this field is in it's use here.

As you've seen, there is an issue for this though: logging.files.permissions setting is not taken into account · Issue #24555 · elastic/beats · GitHub.

1 Like

I guess I'd have to re-compile using a different umask then. Thanks for your help!