Page not found error in stack monitoring page

I am getting 404 - "page not found" while clicking on specific node inside stack management. I am able to get details about other nodes.

image

Here is the URL:

logstash/node/3cba9882-7c93-48d6-ae7c-2c599b01abfa?_g=(cluster_uuid:%27-26z29GGRyWZ-8MuAvjaWw%27,refreshInterval:(pause:!f,value:10000),time:(from:now-1h,to:now))

I am however able to get statistics on the initial stack monitoring page:

URL here is:

/logstash/nodes?_g=(cluster_uuid:'-26z29GGRyWZ-8MuAvjaWw',refreshInterval:(pause:!f,value:10000),time:(from:now-1h,to:now))

What is the error? How do I resolve this?

Do you see an error in the Kibana server logs? If so, is there a matching error in the elasticsearch logs?

This is probably https://github.com/elastic/kibana/issues/69321

The workaround is to manually patch the url to prefix it with the Kibana root url and an # symbol, so it resembles the rest of the urls.

Hi I am running Elasticsearch on a VM with logstash on a Raspberry Pi and I run Kibana from my laptop. I do not see any error in my Kibana console (command prompt on Windows) when I click on this link. I do see other errors such as signal timeout which are unrelated though.

I am sorry that I removed the IP purposely and if misguided your efforts. Here are the full URLs:

Working:

http://1.1.1.1.:5601/app/monitoring/logstash/node/3cba9882-7c93-48d6-ae7c-2c599b01abfa?_g=(cluster_uuid:%27-26z29GGRyWZ-8MuAvjaWw%27,refreshInterval:(pause:!f,value:10000),time:(from:now-1h,to:now))

http://1.1.1.1.:5601/logstash/node/3cba9882-7c93-48d6-ae7c-2c599b01abfa?_g=(cluster_uuid:%27-26z29GGRyWZ-8MuAvjaWw%27,refreshInterval:(pause:!f,value:10000),time:(from:now-1h,to:now))

I have replaced the host ip with 1.1.1.1. If you reckon the problem is as you've said, where do I need to append the #?

Thank you.

The url should be:

http://1.1.1.1.:5601/app/monitoring/#logstash/node/....

Hopefully this helps:

Original URL

http://1.1.1.1:5601/logstash/node/3cba9882-7c93-48d6-ae7c-2c599b01abfa?_g=(cluster_uuid:%27-26z29GGRyWZ-8MuAvjaWw%27,filters:!(),refreshInterval:(pause:!f,value:10000),time:(from:now-10m,to:now))

Edited to:
http://1.1.1.1:5601/app/monitoring/#/logstash/node/3cba9882-7c93-48d6-ae7c-2c599b01abfa?_g=(cluster_uuid:'-26z29GGRyWZ-8MuAvjaWw',filters:!(),refreshInterval:(pause:!f,value:10000),time:(from:now-10m,to:now))

Note that I had put app/monitoring/#logstash but it automatically converted that to app/monitoring/#/logstash

gives the following error:

For my setup, the nodes listing page is:

https://localhost:5601/app/monitoring#/logstash/nodes

When I click on a node, it goes to:

https://localhost:5601/logstash/pipelines/test

which results in a 404. The right url is:

https://localhost:5601/app/monitoring#logstash/pipelines/test

Does applying that to your environment work too?

2 Likes

This works like a charm. Thank you! Same error it seems. :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.