Parentid on frontend end and backend agent is not associated

Kibana version: 7.4

Elasticsearch version: 7.4

APM Server version: 7.6

APM Agent language and version: ASP.NET CORE and javascripts

Browser version: chrome 79

I want to use a to query the link map from the frontend to the backend.
how to do it?

Hi @wajika,

Thanks for using Elastic APM.

The RUM agent adds a special header called elastic-apm-traceparent to http request. This header is needed so that the backend agent (in this case .NET agent) knows to use the correct parent ID. However, this header is only added to same-origin requests by default.

Would you please check the http request to see if elastic-apm-traceparent is added to the headers?

If the request is made to an origin that is different to the one that the page is hosted on, you should add that origin to the distributedTracingOrigins config on the RUM agent. You can find more information on our distributed tracing guide


My frontend ip is and the backend ip is I added the distributedTracingOrigins: ['']

Rum agent is configured as follows

But I checked the browser console and found that the request was rejected.

Can you tell me what's wrong?

There's a typo in the configuration of the RUM agent, you have set DistributedTracingOrigins (with capital D) but the correct config option is distributedTracingOrigins.

Would you please fix the config and try again?

Yes, the problem is solved. Thank you

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.