Performance tune elastic search


I am having issue in elastic serach:
Error: Request to Elasticsearch failed: {"error":{"root_cause":[],"type":"reduce_search_phase_exception","reason":"[reduce] ","phase":"fetch","grouped":true,"failed_shards":[],"caused_by":{"type":"es_rejected_execution_exception","reason":"rejected execution of$2@642eb59 on EsThreadPoolExecutor[search, queue capacity = 1000, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@3d6cd119[Running, pool size = 13, active threads = 13, queued tasks = 1000, completed tasks = 665690]]"}},"status":503}

My Elasticsearch settings are:

bootstrap.memory_lock: true 10.x.x.x
http.port: 9200 es-01 elasticsearch-01 /app/elasticsearch-data
path.logs: /app/elasticsearch/logs
indices.breaker.fielddata.limit: 75%

Kindly suggest the additional settings that would help to get ride of the above error.


Increasing the size of your cluster will help.

Can you suggest the required settings to increase the size of cluster.

Add more memory or more nodes and make the applicable changes depending on which one you do.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.