Permission Denied Error starting Elasticsearch 7.3 from RPM installation RedHat 6.7 Linux

Installed Elasticsearch 7.3 from RPM on RedHat 6.7 machine as root.
sudo rpm --install elasticsearch-7.3.0-x86_64.rpm

Attempted to start using the service commands:
root@seismic-an10:/usr/share/elasticsearch> chkconfig --add elasticsearch
root@seismic-an10:/usr/share/elasticsearch> service elasticsearch start

And I get this error:
Starting elasticsearch: /usr/share/elasticsearch/bin/elasticsearch-env: line 73: /etc/sysconfig/elasticsearch: Permission denied [FAILED]

The permissions of my /etc/sysconfig/elasticsearch file are as follows:
-rw-rw----. 1 root elasticsearch 1613 Jun 20 12:04 elasticsearch

Nothing in the log files:
root@seismic-an10:/var/log/elasticsearch> ls -la
total 8
drwxr-s---. 2 elasticsearch elasticsearch 4096 Jun 20 12:04 .
drwxr-xr-x. 17 root root 4096 Sep 24 10:33 ..

What am I doing wrong?

Services have probably moved to systemctl, iirc, there is some integration with the old chkconfig and system commands, but maybe not enough.

Try "systemctl start elasticsearch" to start it and "systemctl enable elasticsearch" to have it start at reboot.

This machine is running RedHat 6.7 and does not use the systemctl command to start and stop instances. The preferred method is to use the "service start/status/stop" command

I was able to get elasticsearch to start, but had to change permissions for 5 files:
under /etc/elasticsearch:
-rw-rw-r--. 1 root elasticsearch 199 Sep 24 10:33 elasticsearch.keystore
-rw-rw-r--. 1 root elasticsearch 2847 Jun 20 12:04 elasticsearch.yml
-rw-rw-r--. 1 root elasticsearch 3596 Jun 20 12:04 jvm.options
-rw-rw-r--. 1 root elasticsearch 17170 Jun 20 12:04
under /etc/sysconfig:
-rw-rw-r--. 1 root elasticsearch 1613 Jun 20 12:04 elasticsearch

not sure why giving read permission to "other" works here.

Oops, I misread the RedHat verison. 7 came out in 2014, don't see much 6.x anymore.

In ps or something, what user shows for elasticsearch?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.