PHP API for elastic search

Hello,

I have a question about the PHP client for Elasticsearch. I have installed
a local instance of elastic search v1.4.1 and when I tried to install the
PHP API I got an error that said that it was only compatible with versions
1.0 through 1.3. I wanted to use the PHP API for elastic search but if it
isn't compatible with elastic search 1.4 I was going to use the groovy API
client because it is compatible. If anyone else has run into this issue
please let me know what you did to fix the issue. I thought maybe I needed
to update the API but i'm not sure if that is the right solution.

Thanks,
Austin Harmon

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ead4d68d-f46b-463f-beff-7b69af4da7f1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Austin

I am using PHP client with ES1.2.1 and haven't used it with 1.4.1.

Though i'll prefer to use php curl and use rest calls to ES then using ES
php client.

Something like attached test.php.

regards
naveen

On Wednesday, 10 December 2014 23:40:56 UTC+5:30, Austin Harmon wrote:

Hello,

I have a question about the PHP client for Elasticsearch. I have installed
a local instance of elastic search v1.4.1 and when I tried to install the
PHP API I got an error that said that it was only compatible with versions
1.0 through 1.3. I wanted to use the PHP API for elastic search but if it
isn't compatible with elastic search 1.4 I was going to use the groovy API
client because it is compatible. If anyone else has run into this issue
please let me know what you did to fix the issue. I thought maybe I needed
to update the API but i'm not sure if that is the right solution.

Thanks,
Austin Harmon

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bfc875e0-264d-4e55-bc08-b5de22ea84cf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Just to add I think you can use the ES PHP API with 1.4.1 see attached
estest.php

If you are using
this http://www.elasticsearch.org/guide/en/elasticsearch/client/php-api/current/_configuration.html

because rest call is independent of version.

On Wednesday, 10 December 2014 23:40:56 UTC+5:30, Austin Harmon wrote:

Hello,

I have a question about the PHP client for Elasticsearch. I have installed
a local instance of elastic search v1.4.1 and when I tried to install the
PHP API I got an error that said that it was only compatible with versions
1.0 through 1.3. I wanted to use the PHP API for elastic search but if it
isn't compatible with elastic search 1.4 I was going to use the groovy API
client because it is compatible. If anyone else has run into this issue
please let me know what you did to fix the issue. I thought maybe I needed
to update the API but i'm not sure if that is the right solution.

Thanks,
Austin Harmon

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bfaacc02-c46a-4ae5-b0b8-328340d8c88a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.