Pipeline with id does not exist

I'm trying to configure my filebeat.yml file with a pipeline that I created, and it's not working.
I created the pipeline using Ingest Node Pipelines on the ElasticSearch UI.
I get this error:
'pipeline with id does not exist'
This is my configuration file:
cloud.id: "CLOUDID"
cloud.auth: "CLOUDAUTY"

---------------------------- Elasticsearch Output ----------------------------


Array of hosts to connect to.

hosts: ["https://HOST.aws.found.io:9243"]
username: "USERNAME"
password: "PASSWORD"
pipeline: "Pipeline"

This is the error from the filebeat log:

Cache:publisher.EventCache{m:common.MapStr(nil)}} (status=400): {"type":"illegal_argument_exception","reason":"pipeline with id [pipeline] does not exist"}

I already tried to run filebeat setup, and I check with Dev Tools the pipeline, and it seemed ok, like I configured with with grok debugger:

GET _ingest/pipeline/Pipeline

What else can I do?
I'm working on ubuntu 18, with filebeat, i'm not using log stash.


Welcome to this forum! :partying_face:

Have you tried creating the ingest pipeline with lowercase characters only? It is possible that FileBeat converts the uppercase Pipeline into the lowercase pipeline as noted in the error log.

Best regards

1 Like

Thank you so much for that! that was the solution :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.