PLEASE HELP! Problem with tribe node not discovering index

I have a number of clusters running elasticsearch 5.2 and a tribe cluster for cross-cluster search which is all hosted on GCP.
I also have an alias setup on the one index on one of the clusters.

In the process of making changes to the masters of the clusters, I have updated the tribe config on one of the tribe nodes and restarted elasticsearch service , the new config looks like this name of the cluster
    project_id: Project ID
    zone: [zones]
  type: gce
    tags: network-tag
    write: true
    metadata: true
  cluster_1: cluster_1_name ["new_master_1.1", "new_master_1.2"]
  cluster_2: cluster_2_name ["new_master_2.1", "new_master_2.2"] XXXX

Now when I try to run curl localhost:9200/alias/_search it says index not found exception but when I run
curl localhost:9200/index_name/_search i get the expected output.
The old tribe node that I still haven't updated the config for is working fine with both previous curl commands which is intriguing. The only difference in the config is the masters for the clusters.

So I don't know how to fix it. I appreciate all the help I can get in solving this issue.

Thanks a lot.

When I inspect the tribe log it discovers the index the cluster that does not belong to but it doesn't discover it for the cluster that owns it. I'm not sure how this can help identifying the issue and resolving it.

Thanks for joining the Elastic community.
I can't see the issue without testing it..

But given the fact that you are running a pretty old version. Would you mind updating first? We've changed a lot since v5 . Also in regards of CCS to make it more reliable...
What do you think?

@Felix_Roessel Thanks for your reply.
I plan on upgrading soon to the latest version and I know that using a tribe cluster was deprecated in favor of using CCS.
But I need to fix this issue first before upgrading since this is an important cluster.

Any thoughts on the issue I'm facing? Thank you

Unfortunatly I can't help as I never used tribe nodes. But I was posting your question to some collegues. I hope someone find the time to help you.
Another option is to use our support. Are you on a paid subscription?

I managed to fix it because there was a conflict of indices: two clusters had the same index name so all I had to do was add a prefer on conflict.
I will be closing this issue.

Great to year, that you were able to fix it on your own.
Did you thought about using our official support. They can help you much more in depth than we can in this community forum.