[Posible bug] Re: Loss of count accuracy for term facets


(vineeth mohan-2) #1

Kindly look into this. I feel its a bug.

Thanks
Vineeth

On Fri, Nov 22, 2013 at 12:48 PM, vineeth mohan
vm.vineethmohan@gmail.comwrote:

Hi ,

On applying term facets to a field called page with query_string query as
query:* gives me -

  • {
    • term: 10628
    • count: 64
      }

On applying term facets to a field called page with terms query as page:[
10628 ] gives me -

  • {
    • term: 10629
    • count: 100
      }

I tried increasing shard size as follows

"facets": {
"terms": {
"terms": {
"shard_size": 100000000,
"field": "page"
}
}
}

Still no change.

What could be the reason of this discrepancy. Only weird thing i did was
to index some of the feeds again with the same ID using bulk index. But
then , it should be fine.

ES details -

  • number: 0.90.5
  • build_hash: c8714e8e0620b62638f660f6144831792b9dedee
  • build_timestamp: 2013-09-17T12:50:20Z
  • build_snapshot: false
  • lucene_version: 4.4

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

I am unsure I understand your problem. From what I read

  1. You are executing a query, search for anything, facet on field page and
    get back a count of 64 for term 10628
  2. You are executing a query with a term query on field "page" and value
    10628, and it returns results where page field is 10629?

wondering if you are accidentally also searching on the all field with one
of the queries. Can you provide the full queries to make your use case more
clear? Can you reproduce this with a smaller dataset, so we maybe get a
full recreation? That would help a lot.

--Alex

On Sun, Nov 24, 2013 at 11:46 AM, vineeth mohan
vm.vineethmohan@gmail.comwrote:

Kindly look into this. I feel its a bug.

Thanks
Vineeth

On Fri, Nov 22, 2013 at 12:48 PM, vineeth mohan <vm.vineethmohan@gmail.com

wrote:

Hi ,

On applying term facets to a field called page with query_string query as
query:* gives me -

  • {
    • term: 10628
    • count: 64
      }

On applying term facets to a field called page with terms query as page:[
10628 ] gives me -

  • {
    • term: 10629
    • count: 100
      }

I tried increasing shard size as follows

"facets": {
"terms": {
"terms": {
"shard_size": 100000000,
"field": "page"
}
}
}

Still no change.

What could be the reason of this discrepancy. Only weird thing i did was
to index some of the feeds again with the same ID using bulk index. But
then , it should be fine.

ES details -

  • number: 0.90.5
  • build_hash: c8714e8e0620b62638f660f6144831792b9dedee
  • build_timestamp: 2013-09-17T12:50:20Z
  • build_snapshot: false
  • lucene_version: 4.4

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Henrik Nordvik) #3

shard_size was added in 0.90.6 [1]. Upgrade to 0.90.6 or 0.90.7 and it
should work :slight_smile:

[1]
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-facets-terms-facet.html

On Sunday, November 24, 2013 11:46:58 AM UTC+1, vineeth mohan wrote:

Kindly look into this. I feel its a bug.

Thanks
Vineeth

On Fri, Nov 22, 2013 at 12:48 PM, vineeth mohan <vm.vine...@gmail.com<javascript:>

wrote:

Hi ,

On applying term facets to a field called page with query_string query as
query:* gives me -

  • {
    • term: 10628
    • count: 64
      }

On applying term facets to a field called page with terms query as page:[
10628 ] gives me -

  • {
    • term: 10629
    • count: 100
      }

I tried increasing shard size as follows

"facets": {
"terms": {
"terms": {
"shard_size": 100000000,
"field": "page"
}
}
}

Still no change.

What could be the reason of this discrepancy. Only weird thing i did was
to index some of the feeds again with the same ID using bulk index. But
then , it should be fine.

ES details -

  • number: 0.90.5
  • build_hash: c8714e8e0620b62638f660f6144831792b9dedee
  • build_timestamp: 2013-09-17T12:50:20Z
  • build_snapshot: false
  • lucene_version: 4.4

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4