Possible problem in yml config file


#1

I was doing a PUT to ES and got this error:

org.elasticsearch.common.netty.handler.codec.frame.TooLongFrameException:
An HTTP line is larger than 4096 bytes.

I checked the message and it was indeed larger than 4096. So I went to
elasticsearch.yml config file and found:

Set a custom allowed content length:

http.max_content_length: 100mb

in the section configuring the HTTP ports. I uncommented the line can made
the number smaller and saved. Stopped ES and restarted it.
Did the same PUT again. Got the same error. Leads me to believe this
parameter is not correctly being processed at start up.

Anyone out there had the same experience and found another fix for it?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5b075fb6-cb9a-4fa3-8572-421f40b183c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Check indentation. YAML is very sensible.

So if you have:

cluster.name: bla
http.max_content_length: 100mb

The later won't be applied. It must be:
cluster.name: bla
http.max_content_length: 100mb

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 9 août 2014 à 01:48, Sitka sitkawoof@gmail.com a écrit :

I was doing a PUT to ES and got this error:

org.elasticsearch.common.netty.handler.codec.frame.TooLongFrameException: An HTTP line is larger than 4096 bytes.

I checked the message and it was indeed larger than 4096. So I went to elasticsearch.yml config file and found:

Set a custom allowed content length:

http.max_content_length: 100mb

in the section configuring the HTTP ports. I uncommented the line can made the number smaller and saved. Stopped ES and restarted it.
Did the same PUT again. Got the same error. Leads me to believe this parameter is not correctly being processed at start up.

Anyone out there had the same experience and found another fix for it?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5b075fb6-cb9a-4fa3-8572-421f40b183c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CEE95014-8CD3-4924-94D8-3966A396F9D8%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


#3

indentation is okay so that' not it.

On Fri, Aug 8, 2014 at 7:54 PM, David Pilato david@pilato.fr wrote:

Check indentation. YAML is very sensible.

So if you have:

cluster.name: bla
http.max_content_length: 100mb

The later won't be applied. It must be:
cluster.name: bla
http.max_content_length: 100mb

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 9 août 2014 à 01:48, Sitka sitkawoof@gmail.com a écrit :

I was doing a PUT to ES and got this error:

org.elasticsearch.common.netty.handler.codec.frame.TooLongFrameException:
An HTTP line is larger than 4096 bytes.

I checked the message and it was indeed larger than 4096. So I went to
elasticsearch.yml config file and found:

Set a custom allowed content length:

http.max_content_length: 100mb

in the section configuring the HTTP ports. I uncommented the line can
made the number smaller and saved. Stopped ES and restarted it.
Did the same PUT again. Got the same error. Leads me to believe this
parameter is not correctly being processed at start up.

Anyone out there had the same experience and found another fix for it?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5b075fb6-cb9a-4fa3-8572-421f40b183c7%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/5b075fb6-cb9a-4fa3-8572-421f40b183c7%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/BOOtBYLuDSs/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CEE95014-8CD3-4924-94D8-3966A396F9D8%40pilato.fr
https://groups.google.com/d/msgid/elasticsearch/CEE95014-8CD3-4924-94D8-3966A396F9D8%40pilato.fr?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BKDSnEUm7gJOvji9dzEYiJi-rGo%2Bmv7DY8tY6NYFmu%2Bw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4