Problem in Metricbeat for kubernetes monitoring deployed by ECK

In order to monitor my k8s cluster, I deployed Elasticsearch, Kibana and Metricbeat referring to the article this yaml

First I had issues since there was no kube-state-metrics enabled on the cluster, I then referred to some of the articles and enabled kube-state-metrics. Now in my kibana dashboard I can see only metrics of the hosts (cluster nodes) but not metrics of kubernetes resources (Nodes, Pods, Containers, Volumes).

I see this error on the metricbeat pods
error making http request: Get "https://hostname:10250/stats/summary\": lookup hostname on ip: no such host","":"metricbeat","ecs.version":"1.6.0"

I saw a similar post regarding the same where the user describes the below fixed the issue, but I am not sure what that means. Could someone please help if you are able to relate?
" I deployed the yaml by command: cat <<EOD | kubectl -f -
, it caused the $HOSTNAME to convert to local host name and deploy to all nodes with this static host name.
I tried deploy the yaml by file and not by above command and it worked:"

@HadarPeeran could you please help if possible

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.