Problem with ES > 0.90.9 in openvz


(Brian Easley) #1

Hello,

I am unable to properly start elasticsearch 0.90.9 and higher inside Debian
wheezy openvz containers with the following error:

Starting ElasticSearch Server:sysctl: permission denied on key
'vm.max_map_count'

Outside of running this on bare metal, is there any other way to get around
this permission problem? I'm assuming the requirement is coming from some
enhancements to ES to make it more useful with marvel.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/60a119f3-ee3a-491b-8452-abd90b596d28%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #2

I's openvz that does not allow to run sysctl. It's not permission, it's
because of openvz guest architecture. Such a guest does not have access to
the kernel.

You can comment out the sysctl lines and run those commands in the openvz
host instead.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoEUT1%2B4QnmfMS5WLba4T1DYtJg7rXHCxt4-WqwsU6DsjQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Easley) #3

I'm a newcomer to elasticsearch. Where should I comment out the sysctl
lines ?

On Friday, January 31, 2014 2:43:25 PM UTC-6, Jörg Prante wrote:

I's openvz that does not allow to run sysctl. It's not permission, it's
because of openvz guest architecture. Such a guest does not have access to
the kernel.

You can comment out the sysctl lines and run those commands in the openvz
host instead.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2bb8d99b-2cad-4a77-bd62-6b359f0d91a8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #4

Of course in the script where you start Elasticsearch.

https://github.com/elasticsearch/elasticsearch/issues/4397 breaks openvz
(and maybe other VMs)

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHew%3DVGP37cys8mLAA4%3D2wjqUpgJ8fbZGxDUKqnXqNdSA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Easley) #5

I sorted that out, but am still inable to view metrics inside marvel:

No results. There no results because no indices were found that match your
selected time span.

I do see quite a number of elasticsearch metrics inside kibana however,
including: index_stats 1784

Does anyone have any idea on how to get that working ?

On Friday, January 31, 2014 6:49:28 PM UTC-6, Jörg Prante wrote:

Of course in the script where you start Elasticsearch.

https://github.com/elasticsearch/elasticsearch/issues/4397 breaks openvz
(and maybe other VMs)

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ad921d45-1923-4c67-b91a-7d3de0190bbc%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #6

A thought

Have you installed the Marvel plugin at least on the local machine?
By default the marvel website is configured to interrogate localhost.

Tony

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f9286b33-48bc-42e0-a398-c640e5fd553f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #7

Use 0.90.10 or 1.0.0.RC1

Jörg

On Sat, Feb 1, 2014 at 7:03 AM, Brian Easley brian.easley8@gmail.comwrote:

I sorted that out, but am still inable to view metrics inside marvel:

No results. There no results because no indices were found that match
your selected time span.

I do see quite a number of elasticsearch metrics inside kibana however,
including: index_stats 1784

Does anyone have any idea on how to get that working ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFNpCE4DR_TgYMxurun_P47Bc0MvZqS4u3sh%2BzUx_V7vA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Easley) #8

Thank you Jörg,

You've been a great help! I have everything working now.

On Saturday, February 1, 2014 11:24:49 AM UTC-6, Jörg Prante wrote:

Use 0.90.10 or 1.0.0.RC1

Jörg

On Sat, Feb 1, 2014 at 7:03 AM, Brian Easley <brian....@gmail.com<javascript:>

wrote:

I sorted that out, but am still inable to view metrics inside marvel:

No results. There no results because no indices were found that match
your selected time span.

I do see quite a number of elasticsearch metrics inside kibana however,
including: index_stats 1784

Does anyone have any idea on how to get that working ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/edd8c057-7e79-4d6e-8b74-f91e5556e599%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #9