Problem with kibana and index


(philg) #1

Hello
my context : logstash 1.3.2 + ES 0.90.11 + kibana3

I have a perfect pipe of these tools when i send my own logs files
tranformed by logstash ( ES works and kibana also with different
configured dashboards )

but now when i try to send directly json format to ES it works , but
kibana ( configured with the good index ) does not get any data ... -:frowning:

ES head-plugin displays correctly the indexed data , but nothing appears in
kibana
did i miss something important when sending directly json data through

curl -XPOST 'http://localhost:9200/testindex1/testlog' -d @my.json

from the head plugin view of ES, the data is indexed correctly...
Any clue?

philippe

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/22b8529e-1ec7-47a0-92a6-4ca257247768%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(computer engineer) #2

I had a similar issue and the problem was the .conf file in logstash. I had
to ensure tcp input type was set to codex => "json"

On Thursday, February 27, 2014 11:26:55 AM UTC-5, Phil gib wrote:

Hello
my context : logstash 1.3.2 + ES 0.90.11 + kibana3

I have a perfect pipe of these tools when i send my own logs files
tranformed by logstash ( ES works and kibana also with different
configured dashboards )

but now when i try to send directly json format to ES it works , but
kibana ( configured with the good index ) does not get any data ... -:frowning:

ES head-plugin displays correctly the indexed data , but nothing appears
in kibana
did i miss something important when sending directly json data through

curl -XPOST 'http://localhost:9200/testindex1/testlog' -d @my.json

from the head plugin view of ES, the data is indexed correctly...
Any clue?

philippe

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9d61beb4-c815-47db-ad90-8dd7c310e9de%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(philg) #3

hello thanks but the issue is not with logstash ( it works with it) the
issue is without logstash
ie curl ....-X POST.... -> to Kibana

On Thursday, February 27, 2014 6:37:35 PM UTC+1, computer engineer wrote:

I had a similar issue and the problem was the .conf file in logstash. I
had to ensure tcp input type was set to codex => "json"

On Thursday, February 27, 2014 11:26:55 AM UTC-5, Phil gib wrote:

Hello
my context : logstash 1.3.2 + ES 0.90.11 + kibana3

I have a perfect pipe of these tools when i send my own logs files
tranformed by logstash ( ES works and kibana also with different
configured dashboards )

but now when i try to send directly json format to ES it works , but
kibana ( configured with the good index ) does not get any data ... -:frowning:

ES head-plugin displays correctly the indexed data , but nothing appears
in kibana
did i miss something important when sending directly json data through

curl -XPOST 'http://localhost:9200/testindex1/testlog' -d @my.json

from the head plugin view of ES, the data is indexed correctly...
Any clue?

philippe

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0fc3a0d8-b611-4b79-836d-0e74ecf52751%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly-2) #4

Just a thought, almost all queries Kibana sends has a filter on the
@timestamp. In addition it is looking (by default) only in indexes named
logstash-*. If your data does not have that field or has values in that
field that is not in the range that Kibana is looking, or your index does
not match the pattern name in Kibana, you might not see your data. The
easiest way to verify this is you open the inspector on a panel in Kibana,
copy the ES query, and run it yourself and debug from there.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4b66e95d-b364-4873-8ac0-0adf662bc228%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5