Problems configuring a custom analyzer plugin


(g3org) #1

Hello everybody,

for migration of a legacy JSM-based analyzer to el (version 0.19.7) i would
like to wrap the legacy code in a plugin. My plugin gets successfully
loaded on startup but i fail to configure the analyzer correctly. I tried
following configurations (based on default config witch distribution
disabled):

1: index.analysis.analyzer.hda.type:
org.mypackage.elasticsearch.HAnalyzerProvider
2: index.analysis.analyzer.hda.type: "hda"

1: would startup without exception, but curl -XGET
'localhost:9200/myIdx/_analyze?analyzer=hda' -d 'some text' would return
this result:{"error":"RemoteTransportException[[Namorita][inet[/192.168.x.y:9304]][indices/analyze/s]];
nested: ElasticSearchIllegalArgumentException[failed to find analyzer
[hda]]; ","status":400}, whereas the ip-adress does not equal my local
machine's ip.

2: excepts on startup, tries to find a class named "hda" (see
http://pastebin.com/Ryk5x9Jz). Note, that my implementation of
AnalysisBinderProcessor binds "hda" to HAnalyzerProvider.class

I am not sure if my configuration is wrong or if there is a problem with
the distribution. According to the documentation and other plugins (e.g. ik
https://github.com/medcl/elasticsearch-analysis-ik) my configuration
"should" work. Would somebody help me please?

Thanks in advance!

Cheers

Georg


(g3org) #2

solved this: i did not properly invoke the binder processor.


(system) #3