Problems enabling security features

Hi,

I am trying to enable password so that I can create a super user to access some pages after enabling the EDR trial for 30 days in the license management page after setting up ELK stack.
The reason is I got this error when going to Security->Endpoints

So then I ran this command: .\Elasticsearch-setup-passwords interactive
and setup some passwords, but then once I start Kibana, I get this error:

[error][savedobjects-service] Unable to retrieve version information from Elasticsearch nodes. security_exception: [security_exception] Reason: missing authentication credentials for REST request [/_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip]

Anyone have any ideas how I can fix this?

Hi @johnny1891 welcome to the community.

Hopefully you are following the guide here it is really important if you just randomly try to setup security you will have issues

Did you follow this step for setup the users in the kibana.yml so Kibana can connect with Elasticsearch

Configure Kibana to connect to Elasticsearch with a password

Hi,

That solved it. Thanks a lot!

1 Like