Problems on raspberry pi


(Jettro Coenradie) #1

Hi,
I am playing around with a raspberry pi cluster. Most of the things seem to
be running fine. I can see a lot of data about my cluster using the the
marvel plugin. I am however having problems getting data out of the nodes
like cpu, memory etc. So on the cluster overview screen the block with
information about the nodes is empty.

I see a Bad Request error in the log. In the response I see this message:
nested: FacetPhaseExecutionException[Facet [os.cpu.usage]: failed to find
mapping for os.cpu.usage]; }]",

Anybody has an idea how I can debug further?

thanks

Jettro

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/76a204c7-1cf6-4aa1-a291-c0257fbc91d3%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #2

Hi Jettro,

It seems like the cpu data is missing from the documents marvel queries.
Those documents are based on the output of the Node Stats API. That one
uses Sigar to extract this information, with fall back to Jvm based
metrics. My guess is that neither could get the cpu usage on the OS level
(not what the JVM is using). You can confirm by call GET
_cluster/nodes/stats?os (on a 0.90.X version) or GET _nodes/stats/os (on
1.0.X) .

Cheers,
Boaz

On Friday, February 7, 2014 8:27:28 PM UTC+1, Jettro Coenradie wrote:

Hi,
I am playing around with a raspberry pi cluster. Most of the things seem
to be running fine. I can see a lot of data about my cluster using the the
marvel plugin. I am however having problems getting data out of the nodes
like cpu, memory etc. So on the cluster overview screen the block with
information about the nodes is empty.

I see a Bad Request error in the log. In the response I see this message:
nested: FacetPhaseExecutionException[Facet [os.cpu.usage]: failed to find
mapping for os.cpu.usage]; }]",

Anybody has an idea how I can debug further?

thanks

Jettro

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/17bce5a8-b9cd-45bc-aff2-4d923a37db8a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jettro Coenradie) #3

You are right, the problem is with the sugar library. It is missing
the libsigar-arm-linux.so, the arm is not supported. Going to try the jam
based metrics to see if those work.

thanks so far

Op vrijdag 7 februari 2014 20:53:21 UTC+1 schreef Boaz Leskes:

Hi Jettro,

It seems like the cpu data is missing from the documents marvel queries.
Those documents are based on the output of the Node Stats API. That one
uses Sigar to extract this information, with fall back to Jvm based
metrics. My guess is that neither could get the cpu usage on the OS level
(not what the JVM is using). You can confirm by call GET
_cluster/nodes/stats?os (on a 0.90.X version) or GET _nodes/stats/os (on
1.0.X) .

Cheers,
Boaz

On Friday, February 7, 2014 8:27:28 PM UTC+1, Jettro Coenradie wrote:

Hi,
I am playing around with a raspberry pi cluster. Most of the things seem
to be running fine. I can see a lot of data about my cluster using the the
marvel plugin. I am however having problems getting data out of the nodes
like cpu, memory etc. So on the cluster overview screen the block with
information about the nodes is empty.

I see a Bad Request error in the log. In the response I see this message:
nested: FacetPhaseExecutionException[Facet [os.cpu.usage]: failed to find
mapping for os.cpu.usage]; }]",

Anybody has an idea how I can debug further?

thanks

Jettro

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a2d48409-d4f8-4d6b-aa4a-f02ccbfc0397%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jettro Coenradie) #4

Fixed,
It turns out the arm platform was not supported. You can compile your own,
or download the so file from the following post:
https://groups.google.com/forum/#!topic/openhab/18C7FYpxWTQ

Now I need to make marvel nicer for my raspberries, two of three are
constantly over 90%

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/10e2a77f-7720-4e85-b2ab-633c0023e821%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5