Problems when upgrading from 7.5.2 to 7.6.0

Hi,

i using elasicsearch in a docker container with 3 nodes. The configuration I have been using for a long time looks like this:

  • node.name=pear10
  • discovery.seed_hosts=xxx.xx.xx.230,xxx.xx.xx.231,xxx.xx.xx.232
  • cluster.initial_master_nodes=xxx.xx.xx.230,xxx.xx.xx.231,xxx.xx.xx.232
  • cluster.name=monitoring-cluster
  • bootstrap.memory_lock=true

After the upgrade to 7.6.0 i got the following error:
ERROR: setting [cluster.initial_master_nodes] already set, saw [xxx.xx.xx.230,xxx.xx.xx.231,xxx.xx.xx.232] and [xxx.xx.xx.230,xxx.xx.xx.231,xxx.xx.xx.232]

If i remove the settings i got a new error:
the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured

any idea that might help me
regards Philipp

By "remove the settings" do you mean you removed just cluster.initial_master_nodes or did you also remove discovery.seed_hosts? You should leave discovery.seed_hosts in place.

thank you very much for your quick response.
i have removed step by step every setting. only the error message changed slightly until there was no more setting.

Then i got:
the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured

For Example with discovery.seed_host i got:
ERROR: setting [discovery.seed_hosts] already set, saw [xxx.xx.xx.230,xxx.xx.xx.231,xxx.xx.xx.232] and [xxx.xx.xx.230,xxx.xx.xx.231,xxx.xx.xx.232]

Ok, thanks, that clarifies the situation.

It seems that Elasticsearch is picking up these settings twice for some reason. Can you describe your setup a bit more precisely? Are you using docker-compose like in the manual? If so, can you share the full docker-compose.yml? If not, how are you orchestrating these nodes?

(I tried running docker-compose as documented and did not see the effect you are describing)

thanks a lot it works now. The problem was that we build our own container. That's so we could put the uid in (we work with a uid other than 1000). After I took all changes from https://github.com/elastic/dockerfiles/tree/v7.6.0/elasticsearch it worked.

Of course it would be nice to use the original buildscript. Some projects such as grafana allow you to parameterize the build like :
docker build --build-arg GF_UID=714 --build-arg GF_GID=714

regards Philipp

1 Like