Problems with excesive GC


(Matías Waisgold) #1

Hi, i´ve running into some production issues with ES. The GC started to run
all time and the response times went to hell.
This is my bigdesk view:
[image: Imágenes integradas 1]
(The fix was turning it off that's why CPU went to 0%)

In the other hand, i'm seeing this on HQ:
[image: Imágenes integradas 1]

How can I fix it? Are the evictions generating those problems? Any
suggestion?
Thanks in advance

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAMaTqYppJkEnrFbdsdccGzOz0zie7PA40tT0nB%3D9-iDC4Ewn4g%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #2

What ES version is that?

What type of queries do you perform?

What filter cache did you configure?

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFD6s9tau6sb6Dg-qB9jPqWONFv-R343SxN0uzUBv%3DHKw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Matías Waisgold) #3

Between lines.
Thanks!

2014/1/2 joergprante@gmail.com joergprante@gmail.com

What ES version is that?

0.90.8

What type of queries do you perform?

We have a very big query, with lots of filters, and because of that we have
to add them to each facet (we are thinking to move it to a filtered query
instead, do you recomend that?).
We have a cluster of 290Gb of data in 42M of docs in 16 shards with 2
replicas. And 30 nodes.

What filter cache did you configure?

We are using it by default, I think it´s soft with 20% limit.

Jörg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFD6s9tau6sb6Dg-qB9jPqWONFv-R343SxN0uzUBv%3DHKw%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAMaTqYodzv3DfB-iP0bkKWQwf%2BB1RdpEQFYEmO6%3Dkc-iRtB9mA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #4

Filtered query sounds fine.

You should definitely look into your filters and try more efficient ones.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoEaFZRaXzQ8CjAqMrMhUjXGcWhGtB96YUZUMiD%3D-Zt%2BNg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Matías Waisgold) #5

Filtered query did the trick.
Thank's for your time.

2014/1/2 joergprante@gmail.com joergprante@gmail.com

Filtered query sounds fine.

You should definitely look into your filters and try more efficient ones.

Jörg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoEaFZRaXzQ8CjAqMrMhUjXGcWhGtB96YUZUMiD%3D-Zt%2BNg%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAMaTqYp0iMUqKSYTA9TefrX0mX7gPo7j7zjJa64NY5L9KazsHA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6