Problems with plugins (Kopf)


(Invest Ict) #1

I have some troubles with my indexes, so i wanted to install a plugin named
Kopf. So i downloaded the zip file from GIT and placed it on the server.
Next thing i do is:

[root@havok elasticsearch]# bin/plugin -install
lmenezes/elasticsearch-kopf -u file:///root/elasticsearch-kopf-master.zip

-> Installing lmenezes/elasticsearch-kopf...

Trying file:/root/elasticsearch-kopf-master.zip...

Downloading ....................DONE

Installed lmenezes/elasticsearch-kopf into
/usr/share/elasticsearch/plugins/kopf

Identified as a _site plugin, moving to _site structure ...

[root@havok elasticsearch]#

It has installed it in /usr/share/elasticsearch/plugins/kopf and it has
included a _site folder.

But when i go to http://localhost:9200/_plugin/kopf really nothing is
happening. Also replaced localhost with the IP of the server, but still
nothing.

Anyone an idea what i did wrong?

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2a89b5f7-68ac-497f-a65e-a85a32c04d20%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Try adding another / to the end - http://localhost:9200/_plugin/kopf/

On 26 May 2015 at 22:34, Invest Ict info@investict.nl wrote:

I have some troubles with my indexes, so i wanted to install a plugin
named Kopf. So i downloaded the zip file from GIT and placed it on the
server. Next thing i do is:

[root@havok elasticsearch]# bin/plugin -install
lmenezes/elasticsearch-kopf -u file:///root/elasticsearch-kopf-master.zip

-> Installing lmenezes/elasticsearch-kopf...

Trying file:/root/elasticsearch-kopf-master.zip...

Downloading ....................DONE

Installed lmenezes/elasticsearch-kopf into
/usr/share/elasticsearch/plugins/kopf

Identified as a _site plugin, moving to _site structure ...

[root@havok elasticsearch]#

It has installed it in /usr/share/elasticsearch/plugins/kopf and it has
included a _site folder.

But when i go to http://localhost:9200/_plugin/kopf really nothing is
happening. Also replaced localhost with the IP of the server, but still
nothing.

Anyone an idea what i did wrong?

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2a89b5f7-68ac-497f-a65e-a85a32c04d20%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2a89b5f7-68ac-497f-a65e-a85a32c04d20%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X_%2Bs4wcurkOSuseBMqoHaZiS5yQGqwQsOBQNe45hTvW0A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Sumit Gupta) #3

Hi,

After Install Kopf..You restarted you ES or not?
When you restart ES you can see in ES log that plugin is loaded or not.

Thanks,
Sumit


(fateme) #4

hi
i had this problem so i change network.host to ip of server instead of 'localhost' or 127.0.0.1 in
elasticsearch.yml .
its work for me