Problems with Stempel Polish Analysis Plugin


#1

Hi,
I'm a new user to ES. Installed it yesterday (latest version) & mapper-attachment. I'm trying to test how ES is working with Polish language.

Tried to install Stempel
through "plugin install analysis-stempel" and got a success info in cmd.
Analysis-stempel folder was created with 2 .jar files inside and a plugin-descriptor file. I'm trying to use it, but I'm unable to due error:

reason=analyzer [polish] not found for field [content_type]
type=mapper_parsing_exception

ES is not detecting this plugin. _cat/plugins?v does not list it.

How can I solve this ?


(David Pilato) #2

Did you restart the node?


#3

I restarted the service. Does it restart the node ?


(David Pilato) #4

It does.

So if you installed the plugin correctly without any error and if it's not picked up at init time and that you can't see anything in logs, it means to me that the plugin install script did not work as expected.

May be it was installed in another dir than the one expected by elasticsearch.


#5

Logs are clear, no error exactly as you wrote. How can I check which dir is set as default for this plugin by ES.


(David Pilato) #6

May be turning on DEBUG?

Which OS are you using?


#7

Today after restart of OS everything is detected properly, so problem solved :slight_smile: Thank you for your attention and help.
Should I restart the OS after plugin installation ?


(David Pilato) #8

No. I think you did not really restart elasticsearch the first time or it did not stop.


#9

Ok. If im running ES through service stop/start is that restarting ES ? How can I restart it effectively ?


(David Pilato) #10

Should work fine but I don't know your OS and what you installed, messages you got...


(system) #11