ProcessClusterEventTimeoutException in Elasticsearch. Is this timeout value configurable? If yes how?


(Munna) #1

Getting timeout exceptions like below for different index operations.
Below one shows for "index-aliases" operation. I would like to know how
can I configure this timeout value in elasticsearch.yml so that I configure
it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at
org.elasticsearch.cluster.service.InternalClusterService$2$1.run(InternalClusterService.java:237)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT = 

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout = DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8ee9ef0f-e1f2-4230-a7cf-1dfec4eee9b7%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #2

It appears that this value is not configurable. IMHO, it should be, so
perhaps you should open an issue on Github and see if the elasticsearch
team agrees. Better yet, submit a pull request. :slight_smile:

--
Ivan

On Tue, Jan 28, 2014 at 1:08 PM, Ahaduzzaman Munna <
ahaduzzaman.munna@gmail.com> wrote:

Getting timeout exceptions like below for different index operations.
Below one shows for "index-aliases" operation. I would like to know how
can I configure this timeout value in elasticsearch.yml so that I configure
it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at
org.elasticsearch.cluster.service.InternalClusterService$2$1.run(InternalClusterService.java:237)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT =

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout = DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8ee9ef0f-e1f2-4230-a7cf-1dfec4eee9b7%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBs78QWDyaKcL71Spd3775HRT3EN1MZnhn0GakfDkwvSA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Luca Cavanna) #3

The master node timeout is configurable on each call using the
master_timeout parameter. There's no global default exposed as settings
though.

Cheers
Luca

On Wednesday, January 29, 2014 6:32:07 PM UTC+1, Ivan Brusic wrote:

It appears that this value is not configurable. IMHO, it should be, so
perhaps you should open an issue on Github and see if the elasticsearch
team agrees. Better yet, submit a pull request. :slight_smile:

--
Ivan

On Tue, Jan 28, 2014 at 1:08 PM, Ahaduzzaman Munna <ahaduzza...@gmail.com<javascript:>

wrote:

Getting timeout exceptions like below for different index operations.
Below one shows for "index-aliases" operation. I would like to know how
can I configure this timeout value in elasticsearch.yml so that I configure
it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at
org.elasticsearch.cluster.service.InternalClusterService$2$1.run(InternalClusterService.java:237)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT = 

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout = DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8ee9ef0f-e1f2-4230-a7cf-1dfec4eee9b7%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9a0bd096-ce5d-4f2e-9f2d-9c5c34fd374b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Munna) #4

Yes, I feel its little inconvenient not to have that default value
configurable via the config file or an API. I hope ES team do something
about it.
I didn't want to touch my code rather I wanted to have some global
configurable setting to make my life easy ....

On Wed, Jan 29, 2014 at 12:07 PM, Luca Cavanna cavannaluca@gmail.comwrote:

The master node timeout is configurable on each call using the
master_timeout parameter. There's no global default exposed as settings
though.

Cheers
Luca

On Wednesday, January 29, 2014 6:32:07 PM UTC+1, Ivan Brusic wrote:

It appears that this value is not configurable. IMHO, it should be, so
perhaps you should open an issue on Github and see if the elasticsearch
team agrees. Better yet, submit a pull request. :slight_smile:

--
Ivan

On Tue, Jan 28, 2014 at 1:08 PM, Ahaduzzaman Munna <ahaduzza...@gmail.com

wrote:

Getting timeout exceptions like below for different index operations.
Below one shows for "index-aliases" operation. I would like to know how
can I configure this timeout value in elasticsearch.yml so that I configure
it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at org.elasticsearch.cluster.service.InternalClusterService$2$1.
run(InternalClusterService.java:237)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT =

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout = DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8ee9ef0f-e1f2-4230-a7cf-1dfec4eee9b7%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9a0bd096-ce5d-4f2e-9f2d-9c5c34fd374b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CACAuqNukAczguh7zjfwi3kTVzTekkFz%2BMSw0Vm_9xx2K7va05Q%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Luca Cavanna) #5

I see, but now I'm curious on why it takes so long for you to create
aliases, 30 secs seems to be a reasonable default.

On Wed, Jan 29, 2014 at 9:26 PM, Ahaduzzaman Munna <
ahaduzzaman.munna@gmail.com> wrote:

Yes, I feel its little inconvenient not to have that default value
configurable via the config file or an API. I hope ES team do something
about it.
I didn't want to touch my code rather I wanted to have some global
configurable setting to make my life easy ....

On Wed, Jan 29, 2014 at 12:07 PM, Luca Cavanna cavannaluca@gmail.comwrote:

The master node timeout is configurable on each call using the
master_timeout parameter. There's no global default exposed as settings
though.

Cheers
Luca

On Wednesday, January 29, 2014 6:32:07 PM UTC+1, Ivan Brusic wrote:

It appears that this value is not configurable. IMHO, it should be, so
perhaps you should open an issue on Github and see if the elasticsearch
team agrees. Better yet, submit a pull request. :slight_smile:

--
Ivan

On Tue, Jan 28, 2014 at 1:08 PM, Ahaduzzaman Munna <
ahaduzza...@gmail.com> wrote:

Getting timeout exceptions like below for different index operations.
Below one shows for "index-aliases" operation. I would like to know how
can I configure this timeout value in elasticsearch.yml so that I configure
it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at org.elasticsearch.cluster.service.InternalClusterService$2$1.
run(InternalClusterService.java:237)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT =

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout = DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8ee9ef0f-e1f2-4230-a7cf-1dfec4eee9b7%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9a0bd096-ce5d-4f2e-9f2d-9c5c34fd374b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CACAuqNukAczguh7zjfwi3kTVzTekkFz%2BMSw0Vm_9xx2K7va05Q%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADdZ9MWk1M4Anqv_c7_BxFhas_CLXtzqQpzzFdG8v-k%3DwQC59w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Munna) #6

Well. Thats a separate issue. I do not know what exactly happens at ES side
for any index operation. But if it the master timeout is configurable at
once, then it solves a lot of problems.

On Thu, Jan 30, 2014 at 3:38 AM, Luca Cavanna cavannaluca@gmail.com wrote:

I see, but now I'm curious on why it takes so long for you to create
aliases, 30 secs seems to be a reasonable default.

On Wed, Jan 29, 2014 at 9:26 PM, Ahaduzzaman Munna <
ahaduzzaman.munna@gmail.com> wrote:

Yes, I feel its little inconvenient not to have that default value
configurable via the config file or an API. I hope ES team do something
about it.
I didn't want to touch my code rather I wanted to have some global
configurable setting to make my life easy ....

On Wed, Jan 29, 2014 at 12:07 PM, Luca Cavanna cavannaluca@gmail.comwrote:

The master node timeout is configurable on each call using the
master_timeout parameter. There's no global default exposed as settings
though.

Cheers
Luca

On Wednesday, January 29, 2014 6:32:07 PM UTC+1, Ivan Brusic wrote:

It appears that this value is not configurable. IMHO, it should be, so
perhaps you should open an issue on Github and see if the elasticsearch
team agrees. Better yet, submit a pull request. :slight_smile:

--
Ivan

On Tue, Jan 28, 2014 at 1:08 PM, Ahaduzzaman Munna <
ahaduzza...@gmail.com> wrote:

Getting timeout exceptions like below for different index operations.
Below one shows for "index-aliases" operation. I would like to know how
can I configure this timeout value in elasticsearch.yml so that I configure
it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at org.elasticsearch.cluster.service.InternalClusterService$2$1.
run(InternalClusterService.java:237)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT =

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout =

DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8ee9ef0f-e1f2-4230-a7cf-1dfec4eee9b7%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9a0bd096-ce5d-4f2e-9f2d-9c5c34fd374b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CACAuqNukAczguh7zjfwi3kTVzTekkFz%2BMSw0Vm_9xx2K7va05Q%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CADdZ9MWk1M4Anqv_c7_BxFhas_CLXtzqQpzzFdG8v-k%3DwQC59w%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CACAuqNuDL2Dhy%2BO8b1nAvRjnXULokmDuFzYc2oasWrb40JpSMA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


#7

Could someone please give an example of how to go about configuring this
value, or how/where to provide master_timeout? I'm getting a similar issue
when creating mappings, not sure how to go about fixing it. I've read
something in the docs about a zen.discovery.publish_timeout, but I believe
that's something different

[2015-05-22 12:40:06,000][DEBUG][action.admin.indices.mapping.put] failed
to put mappings on indices [index_1432298356915]], type [stuff]
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (put-mapping [stuff]) within 30s at
org.elasticsearch.cluster.service.InternalClusterService$2$1.run(InternalClusterService.java:270)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

On Thursday, 30 January 2014 15:45:59 UTC, Ahaduzzaman Munna wrote:

Well. Thats a separate issue. I do not know what exactly happens at ES
side for any index operation. But if it the master timeout is configurable
at once, then it solves a lot of problems.

On Thu, Jan 30, 2014 at 3:38 AM, Luca Cavanna <cavan...@gmail.com
<javascript:>> wrote:

I see, but now I'm curious on why it takes so long for you to create
aliases, 30 secs seems to be a reasonable default.

On Wed, Jan 29, 2014 at 9:26 PM, Ahaduzzaman Munna <ahaduzza...@gmail.com
<javascript:>> wrote:

Yes, I feel its little inconvenient not to have that default value
configurable via the config file or an API. I hope ES team do something
about it.
I didn't want to touch my code rather I wanted to have some global
configurable setting to make my life easy ....

On Wed, Jan 29, 2014 at 12:07 PM, Luca Cavanna <cavan...@gmail.com
<javascript:>> wrote:

The master node timeout is configurable on each call using the
master_timeout parameter. There's no global default exposed as settings
though.

Cheers
Luca

On Wednesday, January 29, 2014 6:32:07 PM UTC+1, Ivan Brusic wrote:

It appears that this value is not configurable. IMHO, it should be, so
perhaps you should open an issue on Github and see if the elasticsearch
team agrees. Better yet, submit a pull request. :slight_smile:

--
Ivan

On Tue, Jan 28, 2014 at 1:08 PM, Ahaduzzaman Munna <
ahaduzza...@gmail.com> wrote:

Getting timeout exceptions like below for different index operations.
Below one shows for "index-aliases" operation. I would like to know how
can I configure this timeout value in elasticsearch.yml so that I configure
it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at org.elasticsearch.cluster.service.InternalClusterService$2$1.
run(InternalClusterService.java:237)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT = 

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout = 

DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8ee9ef0f-e1f2-4230-a7cf-1dfec4eee9b7%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9a0bd096-ce5d-4f2e-9f2d-9c5c34fd374b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CACAuqNukAczguh7zjfwi3kTVzTekkFz%2BMSw0Vm_9xx2K7va05Q%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CADdZ9MWk1M4Anqv_c7_BxFhas_CLXtzqQpzzFdG8v-k%3DwQC59w%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5171dd69-381f-48ca-8a0d-709c0588a9f3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #8

This thread is nearly 18 months old, you should really create a new one
with a little more detail.

PS - We're moving to https://discuss.elastic.co/, please join us there for
any future discussions!

On 26 May 2015 at 04:36, mzrth_7810 afrazmamoon@gmail.com wrote:

Could someone please give an example of how to go about configuring this
value, or how/where to provide master_timeout? I'm getting a similar issue
when creating mappings, not sure how to go about fixing it. I've read
something in the docs about a zen.discovery.publish_timeout, but I believe
that's something different

[2015-05-22 12:40:06,000][DEBUG][action.admin.indices.mapping.put] failed
to put mappings on indices [index_1432298356915]], type [stuff]
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (put-mapping [stuff]) within 30s at
org.elasticsearch.cluster.service.InternalClusterService$2$1.run(InternalClusterService.java:270)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

On Thursday, 30 January 2014 15:45:59 UTC, Ahaduzzaman Munna wrote:

Well. Thats a separate issue. I do not know what exactly happens at ES
side for any index operation. But if it the master timeout is configurable
at once, then it solves a lot of problems.

On Thu, Jan 30, 2014 at 3:38 AM, Luca Cavanna cavan...@gmail.com wrote:

I see, but now I'm curious on why it takes so long for you to create
aliases, 30 secs seems to be a reasonable default.

On Wed, Jan 29, 2014 at 9:26 PM, Ahaduzzaman Munna <
ahaduzza...@gmail.com> wrote:

Yes, I feel its little inconvenient not to have that default value
configurable via the config file or an API. I hope ES team do something
about it.
I didn't want to touch my code rather I wanted to have some global
configurable setting to make my life easy ....

On Wed, Jan 29, 2014 at 12:07 PM, Luca Cavanna cavan...@gmail.com
wrote:

The master node timeout is configurable on each call using the
master_timeout parameter. There's no global default exposed as settings
though.

Cheers
Luca

On Wednesday, January 29, 2014 6:32:07 PM UTC+1, Ivan Brusic wrote:

It appears that this value is not configurable. IMHO, it should be,
so perhaps you should open an issue on Github and see if the elasticsearch
team agrees. Better yet, submit a pull request. :slight_smile:

--
Ivan

On Tue, Jan 28, 2014 at 1:08 PM, Ahaduzzaman Munna <
ahaduzza...@gmail.com> wrote:

Getting timeout exceptions like below for different index
operations. Below one shows for "index-aliases" operation. I would like to
know how can I configure this timeout value in elasticsearch.yml so that I
configure it once and I do not have to worry about this timeout exception.

org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:
failed to process cluster event (index-aliases) within 30s
at org.elasticsearch.cluster.service.InternalClusterService$2$1.
run(InternalClusterService.java:237)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

I saw in elasticsearch code that

public abstract class MasterNodeOperationRequest extends ActionRequest {

public static TimeValue DEFAULT_MASTER_NODE_TIMEOUT =

TimeValue.timeValueSeconds(30);

protected TimeValue masterNodeTimeout =

DEFAULT_MASTER_NODE_TIMEOUT;

Thanks,
Munna

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8ee9ef0f-
e1f2-4230-a7cf-1dfec4eee9b7%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9a0bd096-ce5d-4f2e-9f2d-9c5c34fd374b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CACAuqNukAczguh7zjfwi3kTVzTekkFz%2BMSw0Vm_9xx2K7va05Q%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/JksDMKjvKvA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CADdZ9MWk1M4Anqv_c7_BxFhas_CLXtzqQpzzFdG8v-k%3DwQC59w%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/


You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5171dd69-381f-48ca-8a0d-709c0588a9f3%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/5171dd69-381f-48ca-8a0d-709c0588a9f3%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-x%3DNjJKUq1oWB5ocJuRiqhkoLzD9kGMFXbJkTS5e6FmA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Anandhakumar Nagarajan) #9

we are getting this exception very often while running operational scripts to create index/add alias.IMHO it would be better to have global configuration for master_timeout property. Do we have any update on this thread?


(Nivetha Veluchamy) #10

We are getting these timeout exceptions very frequently when creating an index or updating a mapping on an index. I would like to understand why these timeouts happen? Why does it require more than 30 seconds to create an index or update mapping?


(system) #11