Puppet catalog error on version 5.2 for systemd

I have an error after playing around with puppet-elasticsearch puppetForge mod version 'elastic-elasticsearch', '5.0.0'.
Here is the error my puppet agent gives me:

puppet-agent[115010]: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: no parameter named 'homedir' at /etc/puppetlabs/code/environments/feature_elk5/modules/elasticsearch/manifests/service/systemd.pp:165 on Elasticsearch_service_file[/lib/systemd/system/elasticsearch-net.elastic.infra.service] at /etc/puppetlabs/code/environments/feature_elk5/modules/elasticsearch/manifests/service/systemd.pp:165 on node syslog03.test

As it don't say in the readme file for puppet-elasticsearch that I need to set an 'homedir' only add an instance name. I have only set my name for the instance and added a own 'datadir'. I use hiera for this, with the "lookup" command.
Anyone else have this problem? Or can help me some to point me in the correct direction at least?

My system is as follows:
Centos 7 as a VM. 8GB RAM, 2 CPU.
Puppet version 4.8.
Installed from Katello version

This is a very common problem when updating puppet modules, and can usually be solved by restarting the puppetmaster.

Alright. Will have to try it then I guess.

Thanks it solved the problem.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.