Query data with punctuation will leads a wrong query result


(chengji18) #1

My case is store some words in index, every word get it's own ID. My query
data is some message. When there are some punctuation in the query data
message, it will give a wrong answer.

For instance, I store keyword "banana" and "green" and "pen" in the index.

My query data1: "is this banana?"

The result will be empty hits.

My query data2: ">> it is a pen"

The symbol ">>" will hits all the keywords in the index.

Without the punctuation the query result will works right.

Any idea about how to use elasticsearch setup to solve this?

Environment Configuration´╝Ü

Ubuntu 12.04 desktop 64 bit Elasticsearch server in Ubuntu, version
0.90.7,single node
Client: pyelasticsearch Programing language: python

Thank you so much!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f1238c65-0c2a-46d5-ac56-69ad149fed0e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Andrew Cholakian-2) #2

Can you post more information. Sample documents, sample queries, etc.


Andrew Cholakian
Developer, Found Hosted Elasticsearch
www.found.no, @foundsays

On Thursday, December 12, 2013 5:19:33 AM UTC-8, cml wrote:

My case is store some words in index, every word get it's own ID. My query
data is some message. When there are some punctuation in the query data
message, it will give a wrong answer.

For instance, I store keyword "banana" and "green" and "pen" in the index.

My query data1: "is this banana?"

The result will be empty hits.

My query data2: ">> it is a pen"

The symbol ">>" will hits all the keywords in the index.

Without the punctuation the query result will works right.

Any idea about how to use elasticsearch setup to solve this?

Environment Configuration´╝Ü

Ubuntu 12.04 desktop 64 bit Elasticsearch server in Ubuntu, version
0.90.7,single node
Client: pyelasticsearch Programing language: python

Thank you so much!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/077d02c1-217b-4f21-958e-6cdb566eec65%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3