Question about HTTP Connection Statistics

Hello all,

I'm wondering why the statistics coming back from my cluster keep reporting
zero http connections, even after explicitly running searches and GET
requests. The only two clients I've used are curl, which is obviously http;
and a python client called pyes, which I assume with pretty high certainty
is http since the only other client i know to use something else (e.g.
transport) is the java client.

Any ideas why this might be?

Thanks for looking,
Adam

HTTP Stats

curl -s "newsdistdeva01:9208/_cluster/nodes/stats?pretty&clear&http"
{
"cluster_name" : "news_dev_alert_es",
"nodes" : {
"1grTyrLOQlaETbSRh-FODQ" : {
"timestamp" : 1366208945581,
"name" : "Doctor Octopus",
"transport_address" : "inet[newsdistdeva01/164.55.92.18:9304]",
"hostname" : "newsdistdeva01",
"attributes" : {
"max_local_storage_nodes" : "1"
},

  •  "http" : {
      "current_open" : 0,
      "total_opened" : 0
    

** }*
}
}
}

Stats Showing get and searches have been run

curl -s "newsdistdeva01:9208/_cluster/nodes/stats?pretty"
{
"cluster_name" : "news_dev_alert_es",
"nodes" : {
"1grTyrLOQlaETbSRh-FODQ" : {
"timestamp" : 1366210452395,
"name" : "Doctor Octopus",
"transport_address" : "inet[newsdistdeva01/164.55.92.18:9304]",
"hostname" : "newsdistdeva01",
"attributes" : {
"max_local_storage_nodes" : "1"
},
"indices" : {
"docs" : {
"count" : 392328,
"deleted" : 0
},
"store" : {
"size" : "565.4mb",
"size_in_bytes" : 592930567,
"throttle_time" : "0s",
"throttle_time_in_millis" : 0
},
"indexing" : {
"index_total" : 392328,
"index_time" : "2.5m",
"index_time_in_millis" : 154459,
"index_current" : 0,
"delete_total" : 0,
"delete_time" : "0s",
"delete_time_in_millis" : 0,
"delete_current" : 0
},
"get" : {
* "total" : 3,*
"get_time" : "1ms",
"time_in_millis" : 1,
"exists_total" : 0,
"exists_time" : "0s",
"exists_time_in_millis" : 0,
"missing_total" : 3,
"missing_time" : "1ms",
"missing_time_in_millis" : 1,
"current" : 0
},
"search" : {
* "query_total" : 5,*
"query_time" : "10ms",
"query_time_in_millis" : 10,
"query_current" : 0,
"fetch_total" : 2,
"fetch_time" : "9ms",
"fetch_time_in_millis" : 9,
"fetch_current" : 0
}
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

SOLVED

The http stats break when using the jetty-authentication plugin (v20.1).

Not sure exactly how the plugin works, but I suspected it of proxying
requests somehow. Read into it a bit more and found this in the
documentation:

The core of the plugin is JettyHttpServerTransport module that works as a

replacement for NettyHttpServerTransport.

I'm guessing the stats api collects its information from the netty server
in a way the jetty server can't replicate.

Thanks to anyone who took the time to read my initial question...

-Adam

On Wed, Apr 17, 2013 at 10:59 AM, Adam Georgiou apg552@gmail.com wrote:

Hello all,

I'm wondering why the statistics coming back from my cluster keep
reporting zero http connections, even after explicitly running searches and
GET requests. The only two clients I've used are curl, which is obviously
http; and a python client called pyes, which I assume with pretty high
certainty is http since the only other client i know to use something else
(e.g. transport) is the java client.

Any ideas why this might be?

Thanks for looking,
Adam

HTTP Stats

curl -s "newsdistdeva01:9208/_cluster/nodes/stats?pretty&clear&http"
{
"cluster_name" : "news_dev_alert_es",
"nodes" : {
"1grTyrLOQlaETbSRh-FODQ" : {
"timestamp" : 1366208945581,
"name" : "Doctor Octopus",
"transport_address" : "inet[newsdistdeva01/164.55.92.18:9304]",
"hostname" : "newsdistdeva01",
"attributes" : {
"max_local_storage_nodes" : "1"
},

  •  "http" : {
      "current_open" : 0,
      "total_opened" : 0
    

** }*
}
}
}

Stats Showing get and searches have been run

curl -s "newsdistdeva01:9208/_cluster/nodes/stats?pretty"
{
"cluster_name" : "news_dev_alert_es",
"nodes" : {
"1grTyrLOQlaETbSRh-FODQ" : {
"timestamp" : 1366210452395,
"name" : "Doctor Octopus",
"transport_address" : "inet[newsdistdeva01/164.55.92.18:9304]",
"hostname" : "newsdistdeva01",
"attributes" : {
"max_local_storage_nodes" : "1"
},
"indices" : {
"docs" : {
"count" : 392328,
"deleted" : 0
},
"store" : {
"size" : "565.4mb",
"size_in_bytes" : 592930567,
"throttle_time" : "0s",
"throttle_time_in_millis" : 0
},
"indexing" : {
"index_total" : 392328,
"index_time" : "2.5m",
"index_time_in_millis" : 154459,
"index_current" : 0,
"delete_total" : 0,
"delete_time" : "0s",
"delete_time_in_millis" : 0,
"delete_current" : 0
},
"get" : {
* "total" : 3,*
"get_time" : "1ms",
"time_in_millis" : 1,
"exists_total" : 0,
"exists_time" : "0s",
"exists_time_in_millis" : 0,
"missing_total" : 3,
"missing_time" : "1ms",
"missing_time_in_millis" : 1,
"current" : 0
},
"search" : {
* "query_total" : 5,*
"query_time" : "10ms",
"query_time_in_millis" : 10,
"query_current" : 0,
"fetch_total" : 2,
"fetch_time" : "9ms",
"fetch_time_in_millis" : 9,
"fetch_current" : 0
}
}
}
}
}

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/2fkyFR1KS2E/unsubscribe?hl=en-US
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

adamgeorgiou.com

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.