RabbitMQ river?


(ibivibiv) #1

Ok, so I have rabbitmq installed with everything defaulted
It is on the same vm as my elasticsearch instance
I followed the setup listed here:

http://www.elasticsearch.org/guide/reference/river/rabbitmq.html

I restarted both elastic and rabbit and then asked rabbit to list all queues. There was no queue named elasticsearch.

I then published messages to a queue named elasticsearch and the list queues then of course showed that queue with a message in it. However (since it was the example message in the above link), there was no index created or documents added/deleted. The message is still sitting in the elasticsearch queue.

If I use a java client and attach it to that queue, it consumes the messages. Did I miss something? How can I check to be sure that elastic is at least attached to that queue?


(ibivibiv) #2

I tried the steps again and same result. Quick thought, are you suppose to have the queue created before you create the river with the XPUT? Trying that now, will post back.


(ibivibiv) #3

Ok, so I found part of my problem actually quite by accident. I guess the logs only ever report the ClassNotFoundException on the initial attempt to create a river. I was attempting to create new versions of the previous one that failed, thinking that my restart of elastic had fixed my classloader issue since the exception vanished on subsequent PUT's to the same river config. Not true. When I created my second river to test creating the queue before registering the river I got the ClassNotFoundException again. I am guessing that the plugin install didn't work as expected. I'll manually install it and see if that helps.


(system) #4