Range query problems


(silvina) #1

Hi,
I want to retrive the last two days of a seller_id, the query is:
{
"from": 0,
"size": 50,
"query": {
"term": {
"seller.id": 4
}
},
"filter": {

      "range": {
        "date_created": {
          "from": "now/d-1d",
          "to": "now",
          "include_lower": false,
          "include_upper": true
        }
      }

}
}

The query return two days: yesterday and two day ago. We had elastic 0.90.3
version and it was working but then we changed to elastic 0.90.8 version
and it didn't work. I don't know if the problem is related to elastic's
version. Any idea about that?

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0e5291f3-8995-4889-8de9-1d3af257cdb3%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

can you provide an example as mentioned in http://elasticsearch.org/help -
so one can reproduce your problem on elasticsearch 0.90.8?

In addition you should try using a filtered query, with a match_all query
and a bool filter, which contains a term filter and a range filter. See
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/query-dsl-filtered-query.html

--Alex

On Fri, Dec 27, 2013 at 11:26 PM, anivlis svlucero@gmail.com wrote:

Hi,
I want to retrive the last two days of a seller_id, the query is:
{
"from": 0,
"size": 50,
"query": {
"term": {
"seller.id": 4
}
},
"filter": {

      "range": {
        "date_created": {
          "from": "now/d-1d",
          "to": "now",
          "include_lower": false,
          "include_upper": true
        }
      }

}
}

The query return two days: yesterday and two day ago. We had elastic
0.90.3 version and it was working but then we changed to elastic 0.90.8
version and it didn't work. I don't know if the problem is related to
elastic's version. Any idea about that?

Thanks.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0e5291f3-8995-4889-8de9-1d3af257cdb3%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM8i8j4Bd8hWg-GMm80bNwtL4Oa4pwkURxfZ8AcUQEd8_w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3