Receiving UNEXPECTED POOL ERROR when using Logstash with Elastic Cloud


(Bill Youngman) #1

I'm trying to set up my test instance for Elastic Cloud so my team can make a presentation to our management team to help in the decision on whether or not to move to the cloud offering however I am having problems getting my logstash instance to connect to my cloud based Elasticsearch instance.

Here is a typical configuration from my logstash.conf file:
elasticsearch {
hosts => "https://8f56ccbee0b8ac7ff5520adc543852de.us-east-1.aws.found.io:9243"
user => "logstash_ingester"
password => "xxxxxxxxxx"
index => "requestlog-%{+YYYY.MM.dd}"
document_type => "requestlogs"
sniffing => false
}

logstash_ingester is a custom user that I created and assigned it to the Superuser role.

The specific error that I am getting is this
UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}

followed by these two messages:

My cluster id is 8f56cc


(Mark Walkom) #2

Can you curl the cluster from the LS host?


(Christian Dahlqvist) #3

Why does your log indicate that your Logstash instance is trying to connect to localhost? Do you have X-Pack installed? How have you set up Logstash? Are you sure it is using the correct config file?


(Bill Youngman) #4

That's what I couldn't figure out but then when you asked about x-pack the light bulb went on. I had installed x-pack for logstash but didn't uninstall it when I signed up for the Cloud trial. So uninstalled and logstash now appears to be working (will know for certain when I can get in Kibana and continue setting things up).

Thanks for the assist.

Bill


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.