Redis: Error fetching data for metricset i/o timeout error

Hi ,

I am trying to use metricbeat (version 8.1.2) module for Redis.
Redis cluster is managed
Also tried with Redis service for the Google Cloud Platform.

Here is config:

  metricsets: ["info", "keyspace"]
  hosts: [""]
  password: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
  enabled: true
  period: 10s
  xpack.enabled: true

Redis hosts

hosts: [""]

Redis AUTH password. Empty by default.

password: (blank if no auth. Tried with password as well as without)

I am getting below errors:

{"log.level":"error","@timestamp":"2022-04-20T12:33:49.090Z","log.origin":{"":"module/wrapper.go","file.line":254},"message":"Error fetching data for metricset redis.keyspace: Failed to fetch redis info for keyspaces: dial tcp i/o timeout","":"metricbeat","ecs.version":"1.6.0"}

{"log.level":"error","@timestamp":"2022-04-20T12:33:51.488Z","log.origin":{"":"redis/redis.go","file.line":70},"message":"Error retrieving INFO stats: dial tcp i/o timeout","":"metricbeat","ecs.version":"1.6.0"}

{"log.level":"error","@timestamp":"2022-04-20T12:33:51.488Z","log.origin":{"":"module/wrapper.go","file.line":254},"message":"Error fetching data for metricset failed to fetch redis info: dial tcp i/o timeout","":"metricbeat","ecs.version":"1.6.0"}

However I can connect via redis-cli to the host. Ping returns Pong.

Also If i try to connect to my local redis running on localhost I am able to see the metrics.
Using hosts: [""]

Any suggestion on what could be the reason?


Hi @Duane_DSouza,

based on the logs you posted it seems to be a network connectivity issue, not a Metricbeat issue.

However I can connect via redis-cli to the host. Ping returns Pong.

Are you running redis-cli from the same machine running Metricbeat and with the same credentials?

Is there any firewall or proxy that might be affecting the network connectivity?

Thanks @TiagoQueiroz ,

Yes I am running redis-cli from the same machine running metricbeat and using the same credentials.

redis-cli -h -p 16058 -a Qa0c9NE3qAFV3B5x49NouDzOen94auNA

Except that metricbeat is deployed in a docker container.
I am not connected to any proxy or firewall.

I am now seeing this issue in the logs. I have moved past the earlier issue.

{"log.level":"error","@timestamp":"2022-04-21T14:44:58.245Z","log.origin":{"":"metrics/metrics.go","file.line":306},"message":"error determining cgroups version: error reading /proc/909352/cgroup: open /proc/909352/cgroup: no such file or directory","":"metricbeat","ecs.version":"1.6.0"}

AM i missing something?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.