Reindex from remote cluster which has https enabled


#1

hi,

I am trying to reindex from a remote source which has SSL enabled. When I use a https host name, I get SSL handshake exception.

Is there a way to pass the certificate path to a reindex from remote request? I checked the documentation and dont see these details.

{
  "error": {
    "root_cause": [
      {
        "type": "s_s_l_handshake_exception",
        "reason": "General SSLEngine problem"
      }
    ],
    "type": "s_s_l_handshake_exception",
    "reason": "General SSLEngine problem",
    "caused_by": {
      "type": "s_s_l_handshake_exception",
      "reason": "General SSLEngine problem",
      "caused_by": {
        "type": "validator_exception",
        "reason": "PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target",
        "caused_by": {
          "type": "sun_cert_path_builder_exception",
          "reason": "unable to find valid certification path to requested target"
        }
      }
    }
  },
  "status": 500
}

Thanks!


How can resolve SSL handshake issue on reindex from remote
(andy_zhou) #2

need set ssl valitue false?


#3

ES endpoint has SSL enabled. So I cannot disable SSL just for reindexing.


(andy_zhou) #4

as i know, you need seting PKI pem . as i remenber elastic have a doc about it.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.