Reindex from remote error: Could not resolve host


(Prad) #1

Hi,

I am trying to upgrade elasticsearch 1.4.4 to 6.5.0. Below are the steps I followed:

  • Started a new 6.5.0 cluster in addition to existing 1.4.4
  • configured it to run with logstash 6.5.0 and it is running well.

I am getting an error when trying to reindex from remote:

curl -X POST “127.0.0.1:9201/_reindex?pretty=true” -H 'Content-Type: application/json' -d'
{
"conflicts": "proceed",
"source": {
"remote": {
"host": “http://localhost:9200"
},
"index": "my_new_twitter_river"
},
"dest": {
"index": “twittertool2.0”
}
}'

For the above, I am getting the below error:

curl: (6) Could not resolve host: “127.0.0.1; Name or service not known

Can anyone help please?


(Nik Everett) #2

That error is from curl. It looks like it is trying to resolve the host icluding the quotation mark. Are you sending a standard quotation mark or some kind of fancy one? It looks like a left quote or a smart quote from here. Neither of those are good.


(Prad) #3

@nik9000 Thanks a lot! That indeed was the problem! I typed in the quote this time and the curl error went. Now I have a new error!

curl -X POST "127.0.0.1:9201/_reindex?pretty=true" -H 'Content-Type: application/json' -d'
{
"conflicts": "proceed",
"source": {
"remote": {
"host": "https://localhost:9200"
},
"index": "my_new_twitter_river"
},
"dest": {
"index": "twittertool2"
}
}'

{
"error" : {
"root_cause" : [
{
"type" : "connection_closed_exception",
"reason" : "Connection closed"
}
],
"type" : "connection_closed_exception",
"reason" : "Connection closed"
},
"status" : 500
}

Any advise on how to work this out?


(Prad) #4

its working now!! just changed https to http!!! Thanks a lot!


(Prad) #5

Facing another error while trying to reindex from remote:

my reindex code:

curl -X POST "127.0.0.1:9201/_reindex?pretty=true" -H 'Content-Type: application/json' -d'
{
"conflicts": "proceed",
"source": {
"remote": {
"host": "http://localhost:9200"
},
"index": "my_new_twitter_river"
},
"dest": {
"index": "twittertool2"
}
}'

Error I am getting:

{
"error" : {
"root_cause" : [
{
"type" : "circuit_breaking_exception",
"reason" : "[parent] Data too large, data for [<http_request>] would be [7430139381/6.9gb], which is larger than the limit of [7345215897/6.8gb], usages [request=0/0b, fielddata=0/0b, in_flight_requests=190/190b, accounting=7430139191/6.9gb]",
"bytes_wanted" : 7430139381,
"bytes_limit" : 7345215897
}
],
"type" : "circuit_breaking_exception",
"reason" : "[parent] Data too large, data for [<http_request>] would be [7430139381/6.9gb], which is larger than the limit of [7345215897/6.8gb], usages [request=0/0b, fielddata=0/0b, in_flight_requests=190/190b, accounting=7430139191/6.9gb]",
"bytes_wanted" : 7430139381,
"bytes_limit" : 7345215897
},
"status" : 503
}

after some search I tried to increase the limit with this :slight_smile:

curl -XPUT localhost:9201/_cluster/settings -H 'Content-Type: application/json' -d '{
"persistent" : {
"indices.breaker.fielddata.limit" : "75%"
}
}'

I got this acknowledgement:

{"acknowledged":true,"persistent":{"indices":{"breaker":{"fielddata":{"limit":"75%"}}}},"transient":{}}

but the error is still not resolved. Can anyone please advise what is going wrong?


(Prad) #6

just to add - any command I run, I am getting the same error!