Reindex incompatible with elasticsearch 2.3.0


(Ayushbij27) #1

As soon as I run a scala program using sbt with elas4s dependencies ,it throws an error
Plugin [reindex] is incompatible with Elasticsearch [2.3.0]. Was designed for version [2.3.5]
even though i am using elasticsearch version 2.3.5.


(Nik Everett) #2

This sounds like a version mismatch in elas4s or your dependencies somewhere. Make sure version of the reindex jar matches the Elasticsearch jar.

These tests are fairly paranoid but they are there to prevent sneaky bugs we've seen in the past. Sorry for the inconvenience!


(Ayushbij27) #3

Thanks! But I still dont get it. The version of elasticsearch which i am using is 2.3.5 and is compatible with elas4s versions 2.3.0 and I have added dependencies in my build.sbt file accordingly.


(Nik Everett) #4

I suspect elas4s is depending on elasticsearch 2.3.0. So you'd use reindex 2.3.0. That should work fine communicating with a 2.3.5 server.


(Ayushbij27) #5

Earlier I was trying with local elasticsearch server,when I tried on the remote server it worked with same version . Thanks @nik9000


(system) #6