Reindexing fails because missing shards

Hi everyone hope you doing ok.
We are trying to reindex data from an index with one missing shard, but we get this error:

{
   "completed":true,
   "task":{
      "node":"node",
      "id":7297895,
      "type":"transport",
      "action":"indices:data/write/reindex",
      "status":{
         "total":0,
         "updated":0,
         "created":0,
         "deleted":0,
         "batches":0,
         "version_conflicts":0,
         "noops":0,
         "retries":{
            "bulk":0,
            "search":0
         },
         "throttled_millis":0,
         "requests_per_second":-1.0,
         "throttled_until_millis":0
      },
      "description":"reindex from [index_name] to [index_name2][_doc]",
      "start_time_in_millis":1674514332924,
      "running_time_in_nanos":960232,
      "cancellable":true,
      "headers":{
         
      }
   },
   "error":{
      "type":"search_phase_execution_exception",
      "reason":"",
      "phase":"can_match",
      "grouped":true,
      "failed_shards":[
         
      ],
      "caused_by":{
         "type":"search_phase_execution_exception",
         "reason":"Search rejected due to missing shards [[index_name][4]]. Consider using allow_partial_search_results setting to bypass this error.",
         "phase":"can_match",
         "grouped":true,
         "failed_shards":[
            
         ]
      }
   }
}

specific error:

Search rejected due to missing shards [[index_name][4]]. Consider using allow_partial_search_results setting to bypass this error.

we also tried to update setting allow_partial_search_results, here is our cluster setting:

{
  "persistent" : {
    "cluster" : {
      "routing" : {
        "allocation" : {
          "cluster_concurrent_rebalance" : "10",
          "node_concurrent_recoveries" : "10",
          "disk" : {
            "watermark" : {
              "low" : "90%",
              "high" : "95%"
            }
          },
          "node_initial_primaries_recoveries" : "10"
        }
      }
    },
    "search" : {
      "default_allow_partial_results" : "true",
      "max_open_scroll_context" : "2048"
    },
    "xpack" : {
      "monitoring" : {
        "collection" : {
          "enabled" : "true"
        }
      }
    }
  },
  "transient" : {
    "cluster" : {
      "routing" : {
        "allocation" : {
          "exclude" : {
            "_ip" : "172.20.20.28"
          }
        }
      }
    },
    "search" : {
      "default_allow_partial_results" : "true",
      "max_open_scroll_context" : "2048"
    }
  }
}

as you see default_allow_partial_results is set to true, but we still cant reindex.
do you know what shoud we do?