Rejecting mapping update to db as thee final mapping would have more than 1 type

I have create logstash-mysql.conf with below configuration. When i am running logstash.bat -f logstatshmysql.cong
I am to see only last table is indexed.

Sample Logstash configuration for creating a simple

Beats -> Logstash -> Elasticsearch pipeline.

input {
jdbc {
jdbc_connection_string => "jdbc:mysql://localhost:3306/db"
jdbc_user => "root"
jdbc_password => "password"

	jdbc_driver_class => "com.mysql.jdbc.Driver"
	statement => "SELECT * FROM meeting"
	type=>"dat_meeting"
}
jdbc {
	jdbc_connection_string => "jdbc:mysql://localhost:3306/db"
	jdbc_user => "root"
	jdbc_password => "password"
	
	jdbc_driver_class => "com.mysql.jdbc.Driver"
	statement => "SELECT * FROM meeting_invities;"
	
	type=>"dat_meeting_invities"
}

}
output {
stdout { codec => json_lines }
elasticsearch {
hosts => "localhost:9200"
index => "meetingroomdb"

	 document_type => "%{type}"   # <- use the type from each input
}

}

In recent versions of Elasticsearch indices can only have one type so you cannot have different types for the two inputs if they are going to the same index. You could instead set a field with the type and filter on this if needed.

Thanks for reply. I am newbie to logstash and elastic search.
Can you suggest sample code for multiple jdbc input plugin with filter

Just remove the type parameter from the jdbc input or Shane this to add field with the type setting.

I have removed type parameter and added tag for each jdbc input.
I am checking in output for tags but still i am getting error and only last table is getting indexed.

Rejecting mapping update to [db] as thee final mapping would have more than 1 type: [meeting_invities, meetingroom
"}}}}