Remove commas from number field

Hi guys.

I am filtering customer id using the below:


On my Kibana dashboard, I see it with , and I would like to take the commas out.


**#** customer-id 389,542,059


**#** customer-id 389542059

I did some changes to the Filter field format but I couldn't find the correct pattern.

Hi @sud0 what kind of visualization are you using on the dashboard?

Have you look at the advanced settings

Specifically format:number:defaultPattern but that will change it for all numbers.

Also you could keep the customer-id as a text and / or keyword data type if you are not planning to do any arithmetic with the number instead of making it an integer.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.