Removing TTL during document update


(slushi) #1

I am trying to remove the TTL setting when doing a document update
(doc_as_upsert) via the java api. I do the following:

UpdateRequestBuilder b = new UpdateRequestBuilder(client);

b.setDocAsUpsert(true);

b.setDoc(dataMap);
...

UpdateRequest request = b.request();

request.doc().ttl(null);

...

If I set a value here instead of null, the TTL is successfully updated.
However passing null doesn't seem to remove the TTL. Is there another way
to do this? The comments for the ttl(Long) method seem to indicate passing
null should reset the TTL (I am on 0.90.11)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0ca00b1d-a7ff-4b38-b69e-63be75886ab3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2