Repositories for YUM Error generated


(调兵虎符) #1

[root@localhost software]# cat /etc/yum.repos.d/elasticsearch.repo
[elasticsearch]
name=Elasticsearch
baseurl=http://packages.elastic.co/elasticsearch/1.5/centos
gpgcheck=1
gpgkey=http://packages.elastic.co/GPG-KEY-elasticsearch
enabled=1
[root@localhost software]# rpm --import https://packages.elastic.co/GPG-KEY-elasticsearch
error: https://packages.elastic.co/GPG-KEY-elasticsearch: import read failed(-1).
[root@localhost software]# rpm --import http://packages.elastic.co/GPG-KEY-elasticsearch
[root@localhost software]# yum install elasticsearch
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile


(Mark Walkom) #2

I think this is a problem with older versions of RPM, what version of CentOS are you on?


(调兵虎符) #3

centos5.8 32bit

[root@localhost kibana-4.0.2-linux-x86]# cat /etc/redhat-release
CentOS release 5.8 (Final)
[root@localhost kibana-4.0.2-linux-x86]# uname -a
Linux localhost 2.6.18-308.el5 #1 SMP Tue Feb 21 20:05:41 EST 2012 i686 i686 i386 GNU/Linux
[root@localhost kibana-4.0.2-linux-x86]# file /bin/ls
/bin/ls: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), stripped
[root@localhost kibana-4.0.2-linux-x86]# rpm --version
RPM version 4.4.2.3


(Mark Walkom) #4

Try telling RPM to ignore the signing, there is a flag for it but I dunno what it is sorry!


(调兵虎符) #5

May be:
gpgcheck=0

AS:
[root@localhost ~]# cat /etc/yum.repos.d/elasticsearch.repo
[elasticsearch]
name=Elasticsearch
baseurl=http://packages.elastic.co/elasticsearch/1.5/centos
gpgcheck=0
gpgkey=http://packages.elastic.co/GPG-KEY-elasticsearch
enabled=1

I have done so.


(调兵虎符) #6

直接打开http://packages.elastic.co/elasticsearch/1.5/centos/
却什么都没有。
但打开http://vault.centos.org/6.6/os/Source/SPackages/至少能看到列表。

Directly open http://packages.elastic.co/elasticsearch/1.5/centos/
But nothing.
But at least be able to see a list of open http://vault.centos.org/6.6/os/Source/SPackages/.


(system) #7