Repository-s3 not uploading snapshot to s3


I am running Elasticsearch on eks cluster. for backup to s3 I have added repository-s3 plugin. When I run following command,

curl -X PUT "localhost:9200/_snapshot/my_s3_repository?pretty" -H 'Content-Type: application/json' -d'
  "type": "s3",
  "settings": {
    "bucket": "uat-k8-elasticsearch-bckup",
    "region": "ap-south-1",
    "endpoint": ""

I receive ..

  "acknowledged" : true

But there is no upload on s3. Let me know how I can debug it.

Thanks in advance.

Hi @suratpyari,

Did you also run snapshot creation in addition to creating the repository?
You need to do another call of the form:

PUT /_snapshot/my_s3_repository/snapshot_1?wait_for_completion=true

to actually create a snapshot in the repository you just created.

See the documentation here for details.

This worked. Thanks a lot. Another question is do I need to change name 'my_s3_repository' for every backup or just changing name of snapshot_1 would work?

No problem!

Just changing the name of the snapshot (in this case snapshot_1) is all you need to do and in fact should do to make use of the incremental nature of snapshots per repository.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.