Require login form to access Kibana dashboard


#1

How do I require a login with a username and password to access Kibana dashboards? Right now if I run Kibana, I am able to get to the dashboards without any sort of login. I have followed all the steps outlined in the user authentication how-to at https://www.elastic.co/guide/en/x-pack/5.6/setting-up-authentication.html, but all that seems to do is prevent Kibana from accessing elasticsearch without a password.


(Tyler Smalley) #2

Are you using Kibana/ES version 5.6?

There is a default password is changeme. You will need to update your kibana.yml to reflect this:

elasticsearch.username: kibana
elasticsearch.password: changeme

You can then either change the password via Kibana, or via the API in the docs you linked to.


#3

I have changed the default password, but the problem is that there is no login page. If I go to localhost:5601 it immediately takes me to the dashboard without needing to authenticate


(Tyler Smalley) #4

Can you please verify if you are using Kibana/ES version 5.6?

Is it possible your session is already authenticated? Can you provide your kibana.yml file?


#5

Yes I am using version 5.6. This is my kibana.yml

    elasticsearch.url: "http://localhost:9200"
    xpack.security.enabled: true
    elsaticsearch.password: "elasticpassword"
    xpack.security.authc.accept_default_password: false

(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.