Required java version for elasticsearch 5.6 java API?


(Hossein Yeganeh Markid) #1

Hi all,

I have a problem with java version (7) using elasticsearch 5.6.7

Caused by: java.lang.UnsupportedClassVersionError: org/elasticsearch/index/query/QueryBuilder : Unsupported major.minor version 52.0 (unable to load class org.elasticsearch.index.query.QueryBuilder)

is there anyway to use this version (5.6.7) of elasticsearch with Java 7?

Thanks in advance


(John Strömblom) #2

Hello,

Elastic requires Java 8 (1.8.0_131 or later):
https://www.elastic.co/guide/en/elasticsearch/reference/5.6/setup.html