Reset the IndexShardRoutingTable?

Heya everybody,

Last night I had an index with many documents and without replicas that had
disk failure resulting in 2 lost shards... This is bad, but we are
currently in the process of reindexing and I just want my cluster to be
back in green in the meantime. I read in another issue, that a dummy method
is to create a similar index locally and move the shard to be recovered.
However, I ran an reroute allocate command with "allow_primary": 1 for
those shards, so when I try to recover with the dummy method this is the
outcome I get; https://gist.github.com/jgagnon1/a4ebc27b17e8451af59e

So my question, is there a way to reset the IndexShardRoutingTable (other
than restarting the whole cluster) to remove the allow_primary setting into
those shards ?

Many thanks

Jerome

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

This was the issue I talked about, is it still doable ?
http://elasticsearch-users.115913.n3.nabble.com/Recovering-after-shard-failure-td4018776.html

On Tuesday, May 7, 2013 3:33:24 PM UTC-4, Jérôme Gagnon wrote:

Heya everybody,

Last night I had an index with many documents and without replicas that
had disk failure resulting in 2 lost shards... This is bad, but we are
currently in the process of reindexing and I just want my cluster to be
back in green in the meantime. I read in another issue, that a dummy method
is to create a similar index locally and move the shard to be recovered.
However, I ran an reroute allocate command with "allow_primary": 1 for
those shards, so when I try to recover with the dummy method this is the
outcome I get; https://gist.github.com/jgagnon1/a4ebc27b17e8451af59e

So my question, is there a way to reset the IndexShardRoutingTable (other
than restarting the whole cluster) to remove the allow_primary setting into
those shards ?

Many thanks

Jerome

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.