Restore v1.5 snapshot into v2.1 cluster


(Akshay Davis) #1

I created a set of snapshots in v1.5 and then upgraded to v2.1. I added the path to the whitelisted set of paths in path.repo and tested creating a snapshot.

That all worked fine, however I am not able to restore any of the snapshots created with the older version of elasticsearch. The snap-{index}.dat and meta-{index}.dat files are missing for the older snapshots, and a snapshot_missing_exception is thrown.

Is there anyway to restore these older snapshots?

-Akshay


(Paul) #2

The first thing you should do is run the migration plugin to determine if the data is suitable for migration to 2.x;

but you will need to restore to a 1.5 instance to determine this.

I believe you could also restore to 1.5 and use a logstash input to read from 1.5 and a logstash output to write to 2.1 (but I haven't tested this myself).


(Akshay Davis) #3

Thanks Paul. I had checked the indexes with the migration plugin, but was hoping for an easier way of restoring the data.

Was this listed in the breaking changes for snapshot and restore? I thought I'd gone through them all, but didn't see anything referring to this.

-Akshay


(Akshay Davis) #4

It appears to be a user error on our part. The archive folder was moved and not all the files were transferred. The metadata files were moved but not the snapshot files. Once this was done the restore functions worked as expected in v2.


(system) #5