River-couch DB


(benhowes) #1

Hi Everyone,

I am sure I am doing something a little bit wrong here. I have an
elastic search (0.13.1) instance running on the same machine as a
couchdb database. I am trying to use the couchdb river to import all
the data, but I am getting this output in the log when I add my db
river:

[2010-12-04 17:09:41,500][INFO ][cluster.metadata ] [Enforcer]
[pages] update_mapping [pages] (dynamic)
[2010-12-04 17:09:58,537][INFO ][cluster.metadata ] [Enforcer]
[_river] update_mapping [pages] (dynamic)
[2010-12-04 17:09:58,549][INFO ][river.couchdb ] [Enforcer]
[couchdb][pages] starting couchdb stream: host [localhost], port
[5985], filter [null], db [pages], indexing to [pages]/[pages]
[2010-12-04 17:09:58,554][WARN ][river.couchdb ] [Enforcer]
[couchdb][pages] ignoring unknown change {"seq":1,"id":"1","changes":
[{"rev":"1-11556c11c55bd679f2acc2adcdd54c0d"}]}

then there is an "ignoring unknown change" message for every object in
my database. One of these messages also appears a few times in between
the other WARN's for each of the docs I am attempting to import:

[2010-12-04 17:09:58,627][INFO ][cluster.metadata ] [Enforcer]
[_river] update_mapping [pages] (dynamic)

But a status of that index shows that it is all healthy, but there are
no docs. I have tried doing a few things, like posting some entries
manually (using REST api, these docs are fine), then importing the
rest as well as making changes to docs in the futon to see if the
_changes stream will work. It doesn't seem to matter what I do, I keep
getting the described problem.

There does seem to be a case here of the same problem:
http://elasticsearch-users.115913.n3.nabble.com/couchdb-river-problem-td1665698.html.
I have been searching over the last few days to try and find the
problem, with no joy at all. I am using a 64bit ubuntu machine with
OpenJDK.

Thanks,
Ben


(Shay Banon) #2

This happens when there is no document provided as part of the changes stream the river listens to from couchdb. Which version of couchdb are you using? The option to add "include_docs=true" to the _changes API was not always there in couch.
On Saturday, December 4, 2010 at 6:28 PM, benhowes wrote:

Hi Everyone,

I am sure I am doing something a little bit wrong here. I have an
elastic search (0.13.1) instance running on the same machine as a
couchdb database. I am trying to use the couchdb river to import all
the data, but I am getting this output in the log when I add my db
river:

[2010-12-04 17:09:41,500][INFO ][cluster.metadata ] [Enforcer]
[pages] update_mapping [pages] (dynamic)
[2010-12-04 17:09:58,537][INFO ][cluster.metadata ] [Enforcer]
[_river] update_mapping [pages] (dynamic)
[2010-12-04 17:09:58,549][INFO ][river.couchdb ] [Enforcer]
[couchdb][pages] starting couchdb stream: host [localhost], port
[5985], filter [null], db [pages], indexing to [pages]/[pages]
[2010-12-04 17:09:58,554][WARN ][river.couchdb ] [Enforcer]
[couchdb][pages] ignoring unknown change {"seq":1,"id":"1","changes":
[{"rev":"1-11556c11c55bd679f2acc2adcdd54c0d"}]}

then there is an "ignoring unknown change" message for every object in
my database. One of these messages also appears a few times in between
the other WARN's for each of the docs I am attempting to import:

[2010-12-04 17:09:58,627][INFO ][cluster.metadata ] [Enforcer]
[_river] update_mapping [pages] (dynamic)

But a status of that index shows that it is all healthy, but there are
no docs. I have tried doing a few things, like posting some entries
manually (using REST api, these docs are fine), then importing the
rest as well as making changes to docs in the futon to see if the
_changes stream will work. It doesn't seem to matter what I do, I keep
getting the described problem.

There does seem to be a case here of the same problem:
http://elasticsearch-users.115913.n3.nabble.com/couchdb-river-problem-td1665698.html.
I have been searching over the last few days to try and find the
problem, with no joy at all. I am using a 64bit ubuntu machine with
OpenJDK.

Thanks,
Ben


(benhowes) #3

That was exactly my problem, thanks very much. Ununtu 10.04 uses
couchdb 0.10, whereas all newer versions use 1.0.1. I have upgraded
and its all working fine now.

After doing the upgrade I had to remove and re-add the river in order
to get the docs imported, which makes sense.

Thanks very much for pointing me in the right direction :slight_smile:

Ben

On Dec 4, 8:19 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

This happens when there is no document provided as part of the changes stream the river listens to from couchdb. Which version of couchdb are you using? The option to add "include_docs=true" to the _changes API was not always there in couch.

On Saturday, December 4, 2010 at 6:28 PM, benhowes wrote:

Hi Everyone,

I am sure I am doing something a little bit wrong here. I have an
elastic search (0.13.1) instance running on the same machine as a
couchdb database. I am trying to use the couchdb river to import all
the data, but I am getting this output in the log when I add my db
river:

[2010-12-04 17:09:41,500][INFO ][cluster.metadata ] [Enforcer]
[pages] update_mapping [pages] (dynamic)
[2010-12-04 17:09:58,537][INFO ][cluster.metadata ] [Enforcer]
[_river] update_mapping [pages] (dynamic)
[2010-12-04 17:09:58,549][INFO ][river.couchdb ] [Enforcer]
[couchdb][pages] starting couchdb stream: host [localhost], port
[5985], filter [null], db [pages], indexing to [pages]/[pages]
[2010-12-04 17:09:58,554][WARN ][river.couchdb ] [Enforcer]
[couchdb][pages] ignoring unknown change {"seq":1,"id":"1","changes":
[{"rev":"1-11556c11c55bd679f2acc2adcdd54c0d"}]}

then there is an "ignoring unknown change" message for every object in
my database. One of these messages also appears a few times in between
the other WARN's for each of the docs I am attempting to import:

[2010-12-04 17:09:58,627][INFO ][cluster.metadata ] [Enforcer]
[_river] update_mapping [pages] (dynamic)

But a status of that index shows that it is all healthy, but there are
no docs. I have tried doing a few things, like posting some entries
manually (using REST api, these docs are fine), then importing the
rest as well as making changes to docs in the futon to see if the
_changes stream will work. It doesn't seem to matter what I do, I keep
getting the described problem.

There does seem to be a case here of the same problem:
http://elasticsearch-users.115913.n3.nabble.com/couchdb-river-problem....
I have been searching over the last few days to try and find the
problem, with no joy at all. I am using a 64bit ubuntu machine with
OpenJDK.

Thanks,
Ben


(system) #4