Routing allocation , more then configured


(Ed) #1

Ok, I am on ELK 2.4 and I am decommissioning a node, I wanted to do it during the day but when I trigger the "Exclude" routing, it starts moving 64 shards and seems to be ignoring the Allocation settings, am I missing something?

Reallocation Command

curl -ks http://hd1melk20lx:9200/_cluster/settings --data-binary @- --no-buffer -XPUT 
<< _EOF_
{
  "persistent" : {
    "cluster.routing.allocation.exclude._name" : "hd1melk23lx-es-data,hd1melk27*,hd1melk28*,hd1melk29*"
  }
}
_EOF_
{"acknowledged":true,"persistent":{"cluster":{"routing":{"allocation":{"exclude":{"_name":"hd1melk23lx-es-data,hd1melk27*,hd1melk28*,hd1melk29*"}}}}},"transient":{}}

In Kopf and in the

and the cat api

Both show 64 reolacting shards

Here are my settings I have set

curl -XPUT $HOSTNAME:9220/_cluster/settings -d '{
        "transient" : {
                "indices.recovery.max_bytes_per_sec": "8000mb",
                "indices.recovery.concurrent_streams": 8,
                "cluster.routing.allocation.node_concurrent_recoveries": 8,
                "cluster.routing.allocation.node_initial_primaries_recoveries": 8,
                "cluster.routing.allocation.cluster_concurrent_rebalance":  8,
                "index.unassigned.node_left.delayed_timeout": "1m",
                "index.refresh_interval" : "60s",
                "cluster.routing.allocation.enable" : "all",
                "cluster.routing.allocation.allow_rebalance" : "indices_all_active",
                "indices.recovery.compress": true

        }
}'

Am I missing something or is there a multiplier that I don't realize?


(Mark Walkom) #2

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them :slight_smile:

Do you have other allocation rules in play


(Ed) #3

Not that I know of, I went though all my other configurations and don't see any, what else would influence the number of relocating shards?


(Ed) #4

curl $HOSTNAME:9220/_cluster/settings?pretty

{
  "persistent" : {
    "cluster" : {
      "routing" : {
        "allocation" : {
          "disable_allocation" : "false",
          "disable_replica_allocation" : "false",
          "exclude" : {
            "_name" : "",
            "_ip" : ""
          },
          "enable" : "all"
        }
      }
    },
    "threadpool" : {
      "bulk" : {
        "queue_size" : "4000",
        "size" : "40"
      },
      "index" : {
        "queue_size" : "600",
        "size" : "16"
      },
      "search" : {
        "queue_size" : "8000",
        "size" : "16"
      }
    },
    "indices" : {
      "store" : {
        "throttle" : {
          "type" : "none",
          "max_bytes_per_sec" : "8000mb"
        }
      }
    }
  },
  "transient" : {
    "cluster" : {
      "routing" : {
        "rebalance" : {
          "enable" : "all"
        },
        "allocation" : {
          "disable_allocation" : "false",
          "disable_replica_allocation" : "false",
          "node_initial_primaries_recoveries" : "8",
          "enable" : "all",
          "allow_rebalance" : "always",
          "cluster_concurrent_rebalance" : "8",
          "node_concurrent_recoveries" : "4"
        }
      }
    },
    "indices" : {
      "recovery" : {
        "compress" : "true",
        "concurrent_streams" : "8",
        "max_bytes_per_sec" : "8000mb"
      }
    }
  }
}

(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.