Russian characters are returned in bad charset


(Andrew) #1

On my Centos 7 workstation i have elasticsearch (ver.5.5.1) service by image: docker.elastic.co/elasticsearch/elasticsearch:5.5.1.

Filesystem type on my workstation is xfs.

I have .tar archive with /usr/share/elasticsearch/data/nodes/0/ contains index structure:
(JSON from kibana)
{
"_index": "fias-addrobj",
"_type": "document",
"_id": "00173aad-ae1a-413e-b73c-d9e573923ef9",
"_score": 1,
"_source": {
"aoid": "00173aad-ae1a-413e-b73c-d9e573923ef9",
"formalname": "Учительский",
"regioncode": "26",
"offname": "Учительский",
"shortname": "проез",
"aolevel": 7,
"parentguid": "2a1c7bdb-05ea-492f-9e1c-b3999f79dcbc",
"aoguid": "1a10726e-c22d-4ed0-b01e-ebe7bce46ddf",
"actstatus": 1
}
}

Trouble with formalname – string, offname – string, shortname – string wrong charset.


(David Pilato) #2

Did you use UTF8 when you sent documents to elasticsearch?


(Andrew) #3

Initially, the data was imported from mysql by python script.
Russian characters returned correctly.
But so that for fast deploy I make .tar of
/usr/share/elasticsearch/data/nodes/0/ my first data
and now I composer-up docker and extract tar to /usr/share/elasticsearch/data/nodes/.

Yesterday I tried change version of elasticsearch - not for luck.
I tried on other clean maschine - not for luck.

Several times for deploy all was ok.

But now not luck.


(Andrew) #4

Success!
The problem was in the wrong encoding of the console.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.