Script_fields giving error


#1

I am using elastic 1.5.0. When I run this block in the query:

"script_fields" : {
"test1" : {
"script" : "doc['actual_air_time'].value * 2",
"lang":"groovy"
}
}

I get an error:

nested: ScriptException[dynamic scripting for [groovy] disabled]

How can I enable groovy script for elastic? Is there any other way to
evaluate "test1" without using script_fields?

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e7f9f5df-79f8-4ed0-9383-4c5c6e816f04%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Read this: http://www.elastic.co/guide/en/elasticsearch/reference/current/modules-scripting.html#_enabling_dynamic_scripting

Note that we moved to https://discuss.elastic.co/

David

Le 6 mai 2015 à 06:26, Mohit Garg mohitgargk@gmail.com a écrit :

I am using elastic 1.5.0. When I run this block in the query:

"script_fields" : {
"test1" : {
"script" : "doc['actual_air_time'].value * 2",
"lang":"groovy"
}
}

I get an error:

nested: ScriptException[dynamic scripting for [groovy] disabled]

How can I enable groovy script for elastic? Is there any other way to evaluate "test1" without using script_fields?

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e7f9f5df-79f8-4ed0-9383-4c5c6e816f04%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/A1130146-5752-4C31-A623-24F7CD6EE3EA%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(system) #3