Search result only with unique value of the specific field


(Slava G ) #1

Hi,
Need some advise.
I have indexed documents, each document has internal id that also indexed
as just another indexed field, this id is not used as indexed document id
(_id).
There could be situation when same document is indexed more than once (each
of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple
instance of the same source document), is there any way to get kind of
distinct results, I mean
to get search result only unique documents, based on some field form the
indexed document ?

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #2

Perhaps the top hits aggregation can help:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-aggregations-metrics-top-hits-aggregation.html

--
Ivan

On Wed, Aug 6, 2014 at 11:21 AM, slavag slavago@gmail.com wrote:

Hi,
Need some advise.
I have indexed documents, each document has internal id that also indexed
as just another indexed field, this id is not used as indexed document id
(_id).
There could be situation when same document is indexed more than once
(each of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple
instance of the same source document), is there any way to get kind of
distinct results, I mean
to get search result only unique documents, based on some field form the
indexed document ?

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDGEPns4eK0DPOp9pgOy0nO4RVS_ZE%2Ba-rr-LOXk_Nn8w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Slava G ) #3

Hi, Thanks for the reply.
I'm trying to define top hits aggregation but getting error : "Parse
Failure [Could not find aggregator type [top_hits] in [single_result]]]; }]"
This is my aggregation definition, first bucket is grouped by id and the
nested bucket is grouped by date and then I want to get only one document
from each nested bucket.

"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "date"
},
"aggs" : {
"single_result" : {
"top_hits" : {
"sort": [
{
"id": {
"order":
"desc"
}
}
],
"_source": {
"include": [
"*"
]
},
"size" : 1
}
}
}
}
}
}
}

What could be issue with my aggregation ? I'm using ES 1.2.1

Thanks

On Wednesday, August 6, 2014 10:06:40 PM UTC+3, Ivan Brusic wrote:

Perhaps the top hits aggregation can help:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-aggregations-metrics-top-hits-aggregation.html

--
Ivan

On Wed, Aug 6, 2014 at 11:21 AM, slavag <sla...@gmail.com <javascript:>>
wrote:

Hi,
Need some advise.
I have indexed documents, each document has internal id that also indexed
as just another indexed field, this id is not used as indexed document id
(_id).
There could be situation when same document is indexed more than once
(each of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple
instance of the same source document), is there any way to get kind of
distinct results, I mean
to get search result only unique documents, based on some field form the
indexed document ?

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #4

This has been added in 1.3.0: https://github.com/elasticsearch/elasticsearch/pull/6124

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 6 août 2014 à 23:49:25, slavag (slavago@gmail.com) a écrit:

Hi, Thanks for the reply.
I'm trying to define top hits aggregation but getting error : "Parse Failure [Could not find aggregator type [top_hits] in [single_result]]]; }]"
This is my aggregation definition, first bucket is grouped by id and the nested bucket is grouped by date and then I want to get only one document from each nested bucket.

"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "date"
},
"aggs" : {
"single_result" : {
"top_hits" : {
"sort": [
{
"id": {
"order": "desc"
}
}
],
"_source": {
"include": [
"*"
]
},
"size" : 1
}
}
}
}
}
}
}

What could be issue with my aggregation ? I'm using ES 1.2.1

Thanks

On Wednesday, August 6, 2014 10:06:40 PM UTC+3, Ivan Brusic wrote:
Perhaps the top hits aggregation can help: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-aggregations-metrics-top-hits-aggregation.html

--
Ivan

On Wed, Aug 6, 2014 at 11:21 AM, slavag sla...@gmail.com wrote:
Hi,
Need some advise.
I have indexed documents, each document has internal id that also indexed as just another indexed field, this id is not used as indexed document id (_id).
There could be situation when same document is indexed more than once (each of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple instance of the same source document), is there any way to get kind of distinct results, I mean
to get search result only unique documents, based on some field form the indexed document ?

Thanks

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53e2a53a.2ae8944a.18f0%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Slava G ) #5

Ooo, my bad, sorry.
In the top_hits explanation page
: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-aggregations-metrics-top-hits-aggregation.html
There was top_docs mentioned, but can't find any other reference to that
aggregator, how can I use it ?

Thanks.

P.S. To include all fields in the _source, * is enough or should I use _all
?

Thanks.

On Thursday, August 7, 2014 12:59:39 AM UTC+3, David Pilato wrote:

This has been added in 1.3.0:
https://github.com/elasticsearch/elasticsearch/pull/6124

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 6 août 2014 à 23:49:25, slavag (sla...@gmail.com <javascript:>) a
écrit:

Hi, Thanks for the reply.
I'm trying to define top hits aggregation but getting error : "Parse
Failure [Could not find aggregator type [top_hits] in [single_result]]]; }]"
This is my aggregation definition, first bucket is grouped by id and the
nested bucket is grouped by date and then I want to get only one document
from each nested bucket.

"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "date"
},
"aggs" : {
"single_result" : {
"top_hits" : {
"sort": [
{
"id": {
"order":
"desc"
}
}
],
"_source": {
"include": [
"*"
]
},
"size" : 1
}
}
}
}
}
}
}

What could be issue with my aggregation ? I'm using ES 1.2.1

Thanks

On Wednesday, August 6, 2014 10:06:40 PM UTC+3, Ivan Brusic wrote:

Perhaps the top hits aggregation can help:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-aggregations-metrics-top-hits-aggregation.html

--
Ivan

On Wed, Aug 6, 2014 at 11:21 AM, slavag sla...@gmail.com wrote:

Hi,
Need some advise.
I have indexed documents, each document has internal id that also
indexed as just another indexed field, this id is not used as indexed
document id (_id).
There could be situation when same document is indexed more than once
(each of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple
instance of the same source document), is there any way to get kind of
distinct results, I mean
to get search result only unique documents, based on some field form the
indexed document ?

Thanks

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cde9a830-5a72-47a2-abd2-114603199578%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #6

Sorry, I meant to specify the version, but I forgot. If you do upgrade,
here is another explanation of top hits:
http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/top-hits.html

--
Ivan

On Wed, Aug 6, 2014 at 2:59 PM, David Pilato david@pilato.fr wrote:

This has been added in 1.3.0:
https://github.com/elasticsearch/elasticsearch/pull/6124

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 6 août 2014 à 23:49:25, slavag (slavago@gmail.com) a écrit:

Hi, Thanks for the reply.
I'm trying to define top hits aggregation but getting error : "Parse
Failure [Could not find aggregator type [top_hits] in [single_result]]]; }]"
This is my aggregation definition, first bucket is grouped by id and the
nested bucket is grouped by date and then I want to get only one document
from each nested bucket.

"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "date"
},
"aggs" : {
"single_result" : {
"top_hits" : {
"sort": [
{
"id": {
"order":
"desc"
}
}
],
"_source": {
"include": [
"*"
]
},
"size" : 1
}
}
}
}
}
}
}

What could be issue with my aggregation ? I'm using ES 1.2.1

Thanks

On Wednesday, August 6, 2014 10:06:40 PM UTC+3, Ivan Brusic wrote:

Perhaps the top hits aggregation can help: http://www.
elasticsearch.org/guide/en/elasticsearch/reference/
current/search-aggregations-metrics-top-hits-aggregation.html

--
Ivan

On Wed, Aug 6, 2014 at 11:21 AM, slavag sla...@gmail.com wrote:

Hi,
Need some advise.
I have indexed documents, each document has internal id that also
indexed as just another indexed field, this id is not used as indexed
document id (_id).
There could be situation when same document is indexed more than once
(each of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple
instance of the same source document), is there any way to get kind of
distinct results, I mean
to get search result only unique documents, based on some field form the
indexed document ?

Thanks

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.53e2a53a.2ae8944a.18f0%40MacBook-Air-de-David.local
https://groups.google.com/d/msgid/elasticsearch/etPan.53e2a53a.2ae8944a.18f0%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQA%3DX4WZM2nLJP%3DZxCm94gJz5EkRJs%3DBBSXhrAM1iEOYyw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Slava G ) #7

I'll definitely upgrade.
Thanks

On Thursday, August 7, 2014 1:07:01 AM UTC+3, Ivan Brusic wrote:

Sorry, I meant to specify the version, but I forgot. If you do upgrade,
here is another explanation of top hits:
http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/top-hits.html

--
Ivan

On Wed, Aug 6, 2014 at 2:59 PM, David Pilato <da...@pilato.fr
<javascript:>> wrote:

This has been added in 1.3.0:
https://github.com/elasticsearch/elasticsearch/pull/6124

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 6 août 2014 à 23:49:25, slavag (sla...@gmail.com <javascript:>) a
écrit:

Hi, Thanks for the reply.
I'm trying to define top hits aggregation but getting error : "Parse
Failure [Could not find aggregator type [top_hits] in [single_result]]]; }]"
This is my aggregation definition, first bucket is grouped by id and the
nested bucket is grouped by date and then I want to get only one document
from each nested bucket.

"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "date"
},
"aggs" : {
"single_result" : {
"top_hits" : {
"sort": [
{
"id": {
"order":
"desc"
}
}
],
"_source": {
"include": [
"*"
]
},
"size" : 1
}
}
}
}
}
}
}

What could be issue with my aggregation ? I'm using ES 1.2.1

Thanks

On Wednesday, August 6, 2014 10:06:40 PM UTC+3, Ivan Brusic wrote:

Perhaps the top hits aggregation can help: http://www.
elasticsearch.org/guide/en/elasticsearch/reference/
current/search-aggregations-metrics-top-hits-aggregation.html

--
Ivan

On Wed, Aug 6, 2014 at 11:21 AM, slavag sla...@gmail.com wrote:

Hi,
Need some advise.
I have indexed documents, each document has internal id that also
indexed as just another indexed field, this id is not used as indexed
document id (_id).
There could be situation when same document is indexed more than once
(each of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple
instance of the same source document), is there any way to get kind of
distinct results, I mean
to get search result only unique documents, based on some field form
the indexed document ?

Thanks

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.53e2a53a.2ae8944a.18f0%40MacBook-Air-de-David.local
https://groups.google.com/d/msgid/elasticsearch/etPan.53e2a53a.2ae8944a.18f0%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d7d48fd4-7865-4422-9767-c48316485db2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Slava G ) #8

Upgraded to 1.3.1 and top hits is working, here the aggs definition:
"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "bckdate"
},
"aggs" : {
"single_result" : {
"top_hits" : {"size": 1}
}
}
}
}
}
}

BUT, if I want to include include fields in the result, when I add
"_source" with just a single field (that is present in the search hist
result) - "subj" I get next error :

ElasticsearchIllegalArgumentException[No matching content type for null]
Here the aggs definition with "_source" :

"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "bckdate"
},
"aggs" : {
"single_result" : {
"top_hits" : {"_source": "subj", "size": 1}
}
}
}
}
}
}

What could be an issue here ? And how can I tell _source to include all
fields.

Thanks.

On Thursday, August 7, 2014 1:09:37 AM UTC+3, slavag wrote:

I'll definitely upgrade.
Thanks

On Thursday, August 7, 2014 1:07:01 AM UTC+3, Ivan Brusic wrote:

Sorry, I meant to specify the version, but I forgot. If you do upgrade,
here is another explanation of top hits:
http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/top-hits.html

--
Ivan

On Wed, Aug 6, 2014 at 2:59 PM, David Pilato da...@pilato.fr wrote:

This has been added in 1.3.0:
https://github.com/elasticsearch/elasticsearch/pull/6124

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 6 août 2014 à 23:49:25, slavag (sla...@gmail.com) a écrit:

Hi, Thanks for the reply.
I'm trying to define top hits aggregation but getting error : "Parse
Failure [Could not find aggregator type [top_hits] in [single_result]]]; }]"
This is my aggregation definition, first bucket is grouped by id and the
nested bucket is grouped by date and then I want to get only one document
from each nested bucket.

"aggs" : {
"id" : {
"terms" : {
"field" : "id"
},
"aggs" : {
"bckdate" : {
"terms" : {
"field" : "date"
},
"aggs" : {
"single_result" : {
"top_hits" : {
"sort": [
{
"id": {
"order":
"desc"
}
}
],
"_source": {
"include": [
"*"
]
},
"size" : 1
}
}
}
}
}
}
}

What could be issue with my aggregation ? I'm using ES 1.2.1

Thanks

On Wednesday, August 6, 2014 10:06:40 PM UTC+3, Ivan Brusic wrote:

Perhaps the top hits aggregation can help: http://www.
elasticsearch.org/guide/en/elasticsearch/reference/
current/search-aggregations-metrics-top-hits-aggregation.html

--
Ivan

On Wed, Aug 6, 2014 at 11:21 AM, slavag sla...@gmail.com wrote:

Hi,
Need some advise.
I have indexed documents, each document has internal id that also
indexed as just another indexed field, this id is not used as indexed
document id (_id).
There could be situation when same document is indexed more than once
(each of the indexed instances will have different elasticsearch _id), when
I search I'm getting result all those documents (including multiple
instance of the same source document), is there any way to get kind of
distinct results, I mean
to get search result only unique documents, based on some field form
the indexed document ?

Thanks

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/afc78f11-6050-4471-baec-7e1d2faddb0b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/edd95f65-c380-410b-9f0f-465dd78e1bad%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.53e2a53a.2ae8944a.18f0%40MacBook-Air-de-David.local
https://groups.google.com/d/msgid/elasticsearch/etPan.53e2a53a.2ae8944a.18f0%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0f59ac8b-248c-4156-b4f7-3aa74a8972d1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #9