server.basePath assistance


#1

Greetings,

I have been struggling to figure out how to proxy Kibana requests on my Docker swarm mode cluster. I am using the "Traefik" reverse proxy, and this works perfectly for domain-based Kibana (e.g. "kibana.domain.com"). I am using the official 5.5.2 Kibana image, with X-Pack removed from the Dockerfile.

What doesn't work is the server.basePath setting. I'm trying to configure Kibana to respect "domain.com/kibana", but all I'm getting is 404 pages. My settings are as follows:

kibana.yml:

  • server.basePath: "/kibana"
  • server.host: "0.0.0.0/0"

Traefik labels:

  • traefik.frontend.rule=Host:domain.com;PathPrefixStrip:/kibana (alternatively, "PathStrip:/kibana")

I don't understand what I'm missing, and I have completely run out of ideas. If anyone could offer me some advise, it would be greatly appreciated.


(Lukas Olson) #2

server.host: "0.0.0.0/0"

Can I ask what the "/0" at the end is for?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.