Service starts but connections refused on public IP and localhost

OK the story so far:

upgraded dev box from 5.6.6 to 6.2.4 for more info see

FYI this is a 1 node cluster, prod is 3 nodes but I need to get dev done first.

I've now got the elastic service to start, if I use the elasticserach.yml.rpmnew as my elasticserach.yml which only contains /var/lib/elasticsearch, path.logs: /var/log/elasticsearch then I can fire curl -XGET -u user:password 'http://localhost:9200/_cat/indices?v' I get back a list of all the indexs that were there before the upgrade.

when I add I get no responce on either localhost or the boxes IP.

if anyone has any suggestions then I'd be very greatful for them.

in the logs I've found

[2018-04-20T11:59:06,347][INFO ][o.e.t.TransportService   ] [HOC_bIV] publish_address {}, bound_addresses {}
[2018-04-20T11:59:06,414][INFO ][o.e.b.BootstrapChecks    ] [HOC_bIV] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2018-04-20T11:59:06,447][ERROR][o.e.b.Bootstrap          ] [HOC_bIV] node validation exception
[1] bootstrap checks failed
[1]: max number of threads [2048] for user [elasticsearch] is too low, increase to at least [4096]
[2018-04-20T11:59:06,453][INFO ][o.e.n.Node               ] [HOC_bIV] stopping ...
[2018-04-20T11:59:06,541][INFO ][o.e.n.Node               ] [HOC_bIV] stopped
[2018-04-20T11:59:06,541][INFO ][o.e.n.Node               ] [HOC_bIV] closing ...
[2018-04-20T11:59:06,562][INFO ][o.e.n.Node               ] [HOC_bIV] closed

so looked up how to increase this and found

edited /etc/security/limits.conf to include

elasticsearch - nproc 4096
root - nproc 4096

but I still get the same error

resolved it

in /usr/lib/systemd/system/elasticsearch.service the NPROC limit was set to 2048 so regardless of what I did in limits.conf it wouldn't change, I had to edit it in that to get it to load.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.